summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormoparisthebest2016-10-28 01:58:58 -0400
committermoparisthebest2016-10-28 01:58:58 -0400
commit17f137121bbce82ae602e8206915294e15d98502 (patch)
tree186dc1daca3ffe44f609c26d106bc8a7b9ec3eff
downloadaur-17f137121bbce82ae602e8206915294e15d98502.tar.gz
Version 1.00-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9076abc0c365
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pkgsync
+ pkgdesc = Sync installed packages across Arch installs
+ pkgver = 1.00
+ pkgrel = 1
+ url = https://github.com/moparisthebest/pkgsync
+ arch = any
+ license = GPL3
+ backup = etc/pkgsync/pkg_blacklist.list
+ backup = etc/pkgsync/pkg_exclude.list
+ backup = etc/default/pkgsync
+ source = https://codeload.github.com/moparisthebest/pkgsync/tar.gz/v1.00
+ sha256sums = 4b1384a806664f673ce0abeb9dcd5506c4951a378deeee360b9eb256491a065b
+
+pkgname = pkgsync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5bf9fde93c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: moparisthebest <admin dot archlinux AT moparisthebest dot com>
+
+pkgname=pkgsync
+pkgver=1.00
+pkgrel=1
+pkgdesc='Sync installed packages across Arch installs'
+arch=('any')
+license=('GPL3')
+url="https://github.com/moparisthebest/$pkgname"
+backup=("etc/$pkgname/pkg_blacklist.list" "etc/$pkgname/pkg_exclude.list" "etc/default/$pkgname")
+source=("https://codeload.github.com/moparisthebest/$pkgname/tar.gz/v$pkgver")
+sha256sums=('4b1384a806664f673ce0abeb9dcd5506c4951a378deeee360b9eb256491a065b')
+
+package() {
+ install -d "${pkgdir}"/etc/{default,$pkgname}/
+
+ cd "$pkgname-$pkgver"
+
+ install -Dm744 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm744 config/*.list "${pkgdir}/etc/$pkgname/"
+ install -Dm744 "config/$pkgname" "${pkgdir}/etc/default/"
+}