summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-09-14 02:05:38 +0300
committerorhun2020-09-14 02:05:38 +0300
commit197082d5e88a3a45a273045dea4c94fae830609e (patch)
treeeb7759d6c6dc5764e6a0d59c6fdc906b338b772c
parent6fec2db6bae9962483efce3e645f0e096f94dae1 (diff)
downloadaur-197082d5e88a3a45a273045dea4c94fae830609e.tar.gz
upgpkg: pkgtop-git 2.4.r0.g639b2fe-1
upstream release Update makedepends and the package function
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7028888f967b..4d00e3d79bec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,8 @@ pkgbase = pkgtop-git
url = https://github.com/orhun/pkgtop
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = go
- depends = git
source = git+https://github.com/orhun/pkgtop
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 6f2a4940355f..4e919a41595b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,7 @@ pkgrel=1
arch=('x86_64')
url="https://github.com/orhun/pkgtop"
license=('GPL3')
-depends=('git')
-makedepends=('go')
+makedepends=('git' 'go')
source=("git+$url")
sha256sums=('SKIP')
@@ -30,5 +29,6 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}/src"
- install -Dm755 "${pkgname%-git}" "$pkgdir/usr/local/bin/${pkgname%-git}"
+ install -Dm 755 "${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm 644 "../README.md" -t "$pkgdir/usr/share/doc/${pkgname%-git}"
} \ No newline at end of file