summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-06-13 13:58:13 +0300
committerSpyros Stathopoulos2015-06-13 13:58:13 +0300
commit6692e42d242db35d161c19c7ba1dc5bb1bc939ad (patch)
tree9d0f8655f06284711c5f3ca6d6e3d809623bceb8
downloadaur-6692e42d242db35d161c19c7ba1dc5bb1bc939ad.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD45
-rw-r--r--pkgupdate.install11
-rw-r--r--pkgupdate.service11
5 files changed, 99 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a99b969b916
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = pkgupdate-git
+ pkgdesc = Simple monitor server for pacman and AUR updates
+ pkgver = 117.d87c556
+ pkgrel = 1
+ url = https://github.com/foucault/pkgupdate
+ install = pkgupdate.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = python-docutils
+ depends = python
+ depends = cron
+ optdepends = pygtk: for the gtk+ client
+ optdepends = gtk3: for the gtk+ 3 client
+ optdepends = python-gobject: for the gtk+ 3 client
+ optdepends = gnome-icon-theme: for the gtk+ clients
+ conflicts = pkgupdate
+ backup = etc/pkgupdate.conf
+ source = pkgupdate::git://github.com/foucault/pkgupdate.git
+ md5sums = SKIP
+
+pkgname = pkgupdate-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c19e6b8f5aab
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+pkgupdate/*
+pkg/*
+src/*
+*.tar.gz
+*.tar.xz
+*.tar.bz2
+*.zip
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3270a65cc64b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Contributor: Spyros Stathopoulos <foucault.online@gmail.com>
+pkgname=pkgupdate-git
+_gitname=pkgupdate
+pkgver=117.d87c556
+pkgrel=1
+pkgdesc="Simple monitor server for pacman and AUR updates"
+arch=('i686' 'x86_64')
+url="https://github.com/foucault/pkgupdate"
+license=('GPL3')
+depends=('python' 'cron')
+conflicts=('pkgupdate')
+backup=('etc/pkgupdate.conf')
+optdepends=('pygtk: for the gtk+ client'
+ 'gtk3: for the gtk+ 3 client'
+ 'python-gobject: for the gtk+ 3 client'
+ 'gnome-icon-theme: for the gtk+ clients')
+makedepends=('git' 'python-docutils')
+source=("${_gitname}::git://github.com/foucault/pkgupdate.git")
+md5sums=('SKIP')
+install='pkgupdate.install'
+
+pkgver() {
+ cd "${srcdir}"/"${_gitname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd "$srcdir/${_gitname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/$_gitname"
+ python setup.py install --prefix=/usr --root="${pkgdir}"
+ # gtk client is a python2 script
+ if [ `grep '#!/usr/bin/python$' "${pkgdir}/usr/bin/pkgupdate_gtk.py"` ]; then
+ sed -i -e "s|/usr/bin/python|/usr/bin/python2|" "${pkgdir}/usr/bin/pkgupdate_gtk.py"
+ fi
+ install -D -m755 "${srcdir}/$_gitname/sync_sandbox.sh" \
+ "${pkgdir}/etc/cron.hourly/sync_sandbox"
+ chmod 600 "${pkgdir}/etc/pkgupdate.conf"
+ install -D -m644 "${srcdir}/$_gitname/pkgupdate.service" \
+ "${pkgdir}/usr/lib/systemd/system/pkgupdate.service"
+}
+# vim:ts=2:sw=2:et
diff --git a/pkgupdate.install b/pkgupdate.install
new file mode 100644
index 000000000000..f0c27a141951
--- /dev/null
+++ b/pkgupdate.install
@@ -0,0 +1,11 @@
+post_install() {
+ echo "As of version 0.5a1 (revision 8f66762d) a new dedicated"
+ echo "configuration file is supplied (/etc/pkgupdate.conf) which"
+ echo "provides the same defaults as the previous rc script did."
+ echo "$(tput bold)The /etc/conf.d/pkgupdate.conf script is dropped.$(tput sgr0)"
+ echo "$(tput bold)Use the new configuration file (/etc/pkgupdate.conf) instead.$(tput sgr0)"
+}
+
+post_upgrade() {
+ post_install $1
+}
diff --git a/pkgupdate.service b/pkgupdate.service
new file mode 100644
index 000000000000..7673884b0795
--- /dev/null
+++ b/pkgupdate.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=PkgUpdate Server
+After=network.target
+
+[Service]
+Type=simple
+PIDFile=/run/pkgupdate.pid
+ExecStart=/usr/bin/pkgupdate_server.py -l /var/log/pkgupdate.log
+
+[Install]
+WantedBy=multi-user.target