summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRajdeep Malakar2024-02-12 23:15:41 +0530
committerRajdeep Malakar2024-02-12 23:15:41 +0530
commit7057aa5ba22ac884b97c70a7a7f66ce4b15a8c11 (patch)
tree223a02549d1e2c0b5e70eefa854331cf291f615e
parent391d613eb3672e343c9e8f70bdf7be1b6cf8db7e (diff)
downloadaur-7057aa5ba22ac884b97c70a7a7f66ce4b15a8c11.tar.gz
fix stripping and version
Signed-off-by: Rajdeep Malakar <rajdeepm.dev@gmail.com>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afd6d9738508..99d18c905356 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pkgx-git
pkgdesc = the last thing you’ll install
pkgver = 1.1.6.996.ga0da42e
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/pkgxdev/pkgx
arch = x86_64
arch = arm
@@ -10,6 +10,7 @@ pkgbase = pkgx-git
makedepends = git
provides = pkgx
conflicts = pkgx
+ options = !strip
source = pkgx::git+https://github.com/pkgxdev/pkgx.git
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index bb2368b553ff..410bbdc695e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="pkgx-git"
_pkgname="pkgx"
pkgver=1.1.6.996.ga0da42e
-pkgrel=1
+pkgrel=2
pkgdesc="the last thing you’ll install"
arch=("x86_64" "arm")
url="https://github.com/pkgxdev/pkgx"
@@ -17,6 +17,7 @@ provides=("pkgx")
conflicts=("pkgx")
source=("$_pkgname::git+https://github.com/pkgxdev/pkgx.git")
b2sums=("SKIP") # Since it's a VCS Package, it makes no sense to have checksums
+options=(!strip)
pkgver() {
cd "$_pkgname"
@@ -28,6 +29,8 @@ pkgver() {
build() {
cd "$_pkgname"
+ # Patch version
+ echo "export default function() { return '${{github.event.inputs.version}}' }" > src/modes/version.ts
deno task compile
}