summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWiktor Kwapisiewicz2022-02-07 10:25:30 +0100
committerWiktor Kwapisiewicz2022-02-07 10:25:30 +0100
commitb9281dccad1ba993c078e9e2acc6ae4e74e8ff97 (patch)
tree1f29d935d7ff299f6c7bec726e1ce11231343652
downloadaur-b9281dccad1ba993c078e9e2acc6ae4e74e8ff97.tar.gz
Add pks-openpgp-card-git package
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD33
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a271f030b95c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pks-openpgp-card-git
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://gitlab.com/sequoia-pgp/pks-openpgp-card
+ arch = x86_64
+ license = LGPL
+ makedepends = cargo
+ provides = pks-openpgp-card
+ conflicts = pks-openpgp-card
+ source = pks-openpgp-card::git+https://gitlab.com/sequoia-pgp/pks-openpgp-card
+ sha512sums = SKIP
+
+pkgname = pks-openpgp-card-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d88f45e20830
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Wiktor Kwapisiewicz <wiktor@metacode.biz>
+
+pkgname=pks-openpgp-card-git
+pkgver=0.1
+pkgrel=1
+license=('LGPL')
+url="https://gitlab.com/sequoia-pgp/pks-openpgp-card"
+arch=('x86_64')
+makedepends=(cargo)
+source=("pks-openpgp-card::git+https://gitlab.com/sequoia-pgp/pks-openpgp-card")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "${srcdir}/${pkgname%-git}"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${pkgname%-git}"
+ install -Dm0644 -t "$pkgdir/usr/lib/systemd/user/" "contrib/${pkgname%-git}.socket"
+ install -Dm0644 -t "$pkgdir/usr/lib/systemd/user/" "contrib/${pkgname%-git}.service"
+}