summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-04-09 13:43:43 -0500
committerDoug Newgard2013-04-09 13:43:43 -0500
commit7e4cef546b6f9bb2598fba6fa2a09ecf919f544e (patch)
tree85548db1717a84863c36a547cbedc45266e8e9f0
parentfd8bc16a4bee9e5b10452f489c88cfd66560a8d2 (diff)
downloadaur-7e4cef546b6f9bb2598fba6fa2a09ecf919f544e.tar.gz
Make pkgver use last changed rev and make it locale-proof
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD6
3 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 779260c636ba..594f36340950 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = e17-places-svn
pkgdesc = Enlightenment module: Manage the mounting of volumes
- pkgver = 82790
+ pkgver = 83648
pkgrel = 1
url = http://code.google.com/p/e17mods/wiki/Places
arch = i686
diff --git a/.gitignore b/.gitignore
index e4fa42cf9be4..1561e82616a2 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
+*/
*~
-src/
-pkg/
*.tar.*
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index 6d27270a5ffc..d7edc3e931ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=e17-places-svn
_pkgname=places
-pkgver=82790
+pkgver=83648
pkgrel=1
pkgdesc="Enlightenment module: Manage the mounting of volumes"
arch=('i686' 'x86_64')
@@ -17,7 +17,9 @@ source=("svn+http://svn.enlightenment.org/svn/e/trunk/E-MODULES-EXTRA/$_pkgname"
md5sums=('SKIP')
pkgver() {
- svnversion "$SRCDEST/$_pkgname"
+ cd "$SRCDEST/$_pkgname"
+
+ LC_ALL=C svn info | awk '/Last Changed Rev/ {print $4}'
}
build() {