summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2013-03-30 01:06:11 -0500
committerDoug Newgard2013-03-30 01:06:11 -0500
commitfd8bc16a4bee9e5b10452f489c88cfd66560a8d2 (patch)
tree948d135b5a0563f91f45e2cebfa655f9f7075f9e
parent2770b93883376eb125c949d77217bd744377a1c0 (diff)
downloadaur-fd8bc16a4bee9e5b10452f489c88cfd66560a8d2.tar.gz
Update for makepkg 4.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
2 files changed, 16 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb3284e58756..779260c636ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = e17-places-svn
- pkgdesc = Enlightenment e17 module: Manage the mounting of volumes
+ pkgdesc = Enlightenment module: Manage the mounting of volumes
pkgver = 82790
pkgrel = 1
url = http://code.google.com/p/e17mods/wiki/Places
@@ -9,8 +9,10 @@ pkgbase = e17-places-svn
makedepends = subversion
depends = enlightenment17
depends = e_dbus
- provides = e17-places
+ conflicts = e-modules-extra
options = !libtool
+ source = svn+http://svn.enlightenment.org/svn/e/trunk/E-MODULES-EXTRA/places
+ md5sums = SKIP
pkgname = e17-places-svn
diff --git a/PKGBUILD b/PKGBUILD
index c4afd02dc036..6d27270a5ffc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,48 +2,37 @@
# Contributor: fancris3 <fancris3 at aol.com>
pkgname=e17-places-svn
+_pkgname=places
pkgver=82790
pkgrel=1
-pkgdesc="Enlightenment e17 module: Manage the mounting of volumes"
+pkgdesc="Enlightenment module: Manage the mounting of volumes"
arch=('i686' 'x86_64')
url="http://code.google.com/p/e17mods/wiki/Places"
license=('BSD')
depends=('enlightenment17' 'e_dbus')
makedepends=('subversion')
-provides=('e17-places')
+conflicts=('e-modules-extra')
options=('!libtool')
+source=("svn+http://svn.enlightenment.org/svn/e/trunk/E-MODULES-EXTRA/$_pkgname")
+md5sums=('SKIP')
-_svntrunk=http://svn.enlightenment.org/svn/e/trunk/E-MODULES-EXTRA/places
-_svnmod=places
+pkgver() {
+ svnversion "$SRCDEST/$_pkgname"
+}
build() {
- cd "$srcdir"
-
- msg "Connecting to SVN server...."
-
- if [[ -d "$_svnmod/.svn" ]]; then
- (cd "$_svnmod" && svn up -r "$pkgver")
- else
- svn co "$_svntrunk" --config-dir ./ -r "$pkgver" "$_svnmod"
- fi
-
- msg "SVN checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_svnmod-build"
- svn export "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
- cd "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_pkgname"
./autogen.sh --prefix=/usr
+
make
}
package() {
- cd "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_pkgname"
+
make DESTDIR="$pkgdir" install
# install license files
install -D -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
-
- rm -r "$srcdir/$_svnmod-build"
}