summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Bushchik2022-05-08 08:20:06 +0300
committerIvan Bushchik2022-05-08 08:20:06 +0300
commit243a150050cc902e4ed176e825c77b53ae1b880a (patch)
tree7701b4cb5b9e7f332d16d40eb2bd2c31cb05da9d
downloadaur-243a150050cc902e4ed176e825c77b53ae1b880a.tar.gz
Release v0.1.2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD26
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..27c91dfd15af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = plainabout
+ pkgdesc = plainDE panel
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://plainde.org
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ depends = qt6-base
+ depends = noto-fonts-emoji
+ depends = polkit
+ depends = ttf-opensans
+ depends = make
+ depends = alsa-utils
+ depends = kwindowsystem
+ source = git+https://github.com/plainDE/plainAbout.git#tag=v0.1.2
+ sha256sums = SKIP
+
+pkgname = plainabout
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2345c04eb13c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ivan 'ivabus' Bushchik ivabus@ivabus.dev -> https://github.com/ivabus
+
+pkgname=plainabout
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="plainDE panel"
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="https://plainde.org"
+license=(GPL3)
+depends=(qt6-base noto-fonts-emoji polkit ttf-opensans make alsa-utils kwindowsystem)
+makedepends=(git)
+source=("git+https://github.com/plainDE/plainAbout.git#tag=v${pkgver}")
+sha256sums=('SKIP')
+
+build() {
+ cd $srcdir/plainAbout
+ qmake
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/plainDE/ $pkgdir/usr/bin
+ mv $srcdir/plainPanel/plainAbout $pkgdir/usr/share/plainDE/
+ ln -s $pkgdir/usr/share/plainDE/plainAbout $pkgdir/usr/bin/plainAbout
+}
+