summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Bushchik2022-06-21 09:21:43 +0300
committerIvan Bushchik2022-06-21 09:21:43 +0300
commit89dd70ada6614770248f66f2a35317e161930c55 (patch)
treeb613c5f84cfb9cd4cbbaa2df421ed1961018d85f
parent79a7fad8587d3691713aa7d94a59d779ae159129 (diff)
downloadaur-89dd70ada6614770248f66f2a35317e161930c55.tar.gz
Update to 0.2
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD7
2 files changed, 24 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1928eaa99fb..6b5a08ef0f34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,24 @@
pkgbase = plainabout
- pkgdesc = plainDE about screen
- pkgver = 0.1.4
- pkgrel = 1
- url = https://plainde.org
- arch = x86_64
- arch = i686
- arch = arm
- arch = armv6h
- arch = armv7h
- arch = aarch64
- license = GPL3
- makedepends = git
- depends = qt6-base
- depends = noto-fonts-emoji
- depends = polkit
- depends = ttf-opensans
- depends = make
- source = git+https://github.com/plainDE/plainAbout.git#tag=0.1.4
- sha256sums = SKIP
+ pkgdesc = plainDE about screen
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://plainde.org
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ depends = qt6-base
+ depends = noto-fonts-emoji
+ depends = polkit
+ depends = ttf-opensans
+ depends = make
+ depends = plainbase
+ conflicts = plainabout-git
+ source = git+https://github.com/plainDE/plainAbout.git#tag=0.2
+ sha256sums = SKIP
pkgname = plainabout
diff --git a/PKGBUILD b/PKGBUILD
index e4b95699581e..8b94c2f59d8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Ivan 'ivabus' Bushchik ivabus@ivabus.dev -> https://github.com/ivabus
pkgname=plainabout
-pkgver=0.1.4
+pkgver=0.2
pkgrel=1
pkgdesc="plainDE about screen"
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://plainde.org"
license=(GPL3)
-depends=(qt6-base noto-fonts-emoji polkit ttf-opensans make)
+depends=(qt6-base noto-fonts-emoji polkit ttf-opensans make plainbase)
makedepends=(git)
source=("git+https://github.com/plainDE/plainAbout.git#tag=${pkgver}")
sha256sums=('SKIP')
@@ -22,6 +22,5 @@ build() {
package() {
mkdir -p $pkgdir/usr/bin
- cp $srcdir/plainAbout/plainAbout $pkgdir/usr/bin/
+ install -m 0755 $srcdir/plainAbout/plainAbout $pkgdir/usr/bin/plainAbout
}
-