summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat2023-06-07 21:16:52 +0700
committerAskhat2023-06-07 21:16:52 +0700
commitf72213c6eb3c8c49bdf6aa5293b49e0db4422f2e (patch)
treea196d30e5555980d54efa91cef72e6ba5683f835
parent487566eb7f15ec3e57b4238b44c890312c641cb6 (diff)
downloadaur-f72213c6eb3c8c49bdf6aa5293b49e0db4422f2e.tar.gz
Updated to 0.5.2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d0ee99abdbf..27cc00671676 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = plainabout
pkgdesc = plainDE about screen
- pkgver = 0.5
+ pkgver = 0.5.2
pkgrel = 1
- url = https://plainde.org
+ url = https://plainde.github.io
arch = x86_64
arch = i686
arch = pentium4
@@ -11,15 +11,14 @@ pkgbase = plainabout
arch = armv7h
arch = aarch64
license = GPL3
- makedepends = git
- depends = qt6-base
+ depends = qt5-base
depends = noto-fonts-emoji
depends = polkit
depends = ttf-opensans
depends = make
depends = plainbase
conflicts = plainabout-git
- source = git+https://github.com/plainDE/plainAbout.git#tag=0.4.2
- sha256sums = SKIP
+ source = plainabout-0.5.2.tar.gz::https://github.com/plainDE/plainAbout/archive/refs/tags/0.5.2.tar.gz
+ sha256sums = 206adc9a949e8b569e12df3ba0fd384ef12ad5af8dc9a4539b6e840809d54985
pkgname = plainabout
diff --git a/PKGBUILD b/PKGBUILD
index ab2687162c2f..e0f5ae462c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,29 @@
# Maintainer: Ivan 'ivabus' Bushchik ivabus@ivabus.dev -> https://github.com/ivabus
pkgname=plainabout
-pkgver=0.5
+_pkgname=plainAbout
+pkgver=0.5.2
pkgrel=1
pkgdesc="plainDE about screen"
arch=(x86_64 i686 pentium4 arm armv6h armv7h aarch64)
-url="https://plainde.org"
+url="https://plainde.github.io"
license=(GPL3)
depends=(qt5-base noto-fonts-emoji polkit ttf-opensans make plainbase)
-makedepends=(git)
-source=("git+https://github.com/plainDE/plainAbout.git#tag=${pkgver}")
-sha256sums=('SKIP')
-conflicts=('plainabout-git')
+makedepends=()
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/plainDE/${_pkgname}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('206adc9a949e8b569e12df3ba0fd384ef12ad5af8dc9a4539b6e840809d54985')
+conflicts=('plainabout-git')
build() {
- cd $srcdir/plainAbout
+ cd "${_pkgname}-${pkgver}"
+
qmake
make
}
package() {
- mkdir -p $pkgdir/usr/bin
- install -m 0755 $srcdir/plainAbout/plainAbout $pkgdir/usr/bin/plainAbout
+ cd "${_pkgname}-${pkgver}"
+
+ install -Dm 755 "${_pkgname}" "$pkgdir/usr/bin/${_pkgname}"
}