summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvan Bushchik2022-05-11 20:34:50 +0300
committerIvan Bushchik2022-05-11 20:34:50 +0300
commit0325292b872eb774b3e65dc915f5a0974db72194 (patch)
tree34e5a216c9b631d63ac45aa040231a5fe41a8635
downloadaur-0325292b872eb774b3e65dc915f5a0974db72194.tar.gz
FIX NAME
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..759ca5746d2c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = plainabout-git
+ pkgdesc = plainDE about screen
+ pkgver = 0.1.3.r4.g47be0fe
+ pkgrel = 1
+ url = https://plainde.org
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ depends = qt6-base
+ depends = noto-fonts-emoji
+ depends = polkit
+ depends = ttf-opensans
+ depends = make
+ conflicts = plainabout
+ source = git+https://github.com/plainDE/plainAbout.git
+ sha256sums = SKIP
+
+pkgname = plainabout-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..412acebc6d5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ivan 'ivabus' Bushchik ivabus@ivabus.dev -> https://github.com/ivabus
+
+pkgname=plainabout-git
+pkgver=0.1.3.r4.g47be0fe
+pkgrel=1
+pkgdesc="plainDE about screen"
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
+url="https://plainde.org"
+license=(GPL3)
+depends=(qt6-base noto-fonts-emoji polkit ttf-opensans make)
+makedepends=(git)
+source=("git+https://github.com/plainDE/plainAbout.git")
+sha256sums=('SKIP')
+conflicts=('plainabout')
+
+pkgver() {
+ cd $srcdir/plainAbout
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/plainAbout
+ echo "QString version(){return \"$(git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')\";}" > version.cpp
+ qmake6
+ make
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp $srcdir/plainAbout/plainAbout $pkgdir/usr/bin/
+}
+