summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rembrandt2022-08-27 21:23:14 +0200
committerAndrew Rembrandt2022-08-27 21:29:16 +0200
commit618f4acd48f905a07fbbcb3f83b8b549bf7150b3 (patch)
treec6629b3abf7e110a31a42a6311658b7fbc10ab1e
downloadaur-618f4acd48f905a07fbbcb3f83b8b549bf7150b3.tar.gz
Initial release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65ea2d633567
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = plainmail2html-git
+ pkgdesc = Mutt utility to send HTML formatted Emails
+ pkgver = r28.3da0335
+ pkgrel = 1
+ url = https://github.com/amitramon/plainMail2HTML
+ arch = any
+ license = GPL
+ depends = python-docutils
+ provides = plainmail2html
+ source = git+https://github.com/amitramon/plainmail2html.git
+ sha256sums = SKIP
+
+pkgname = plainmail2html-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6db7d168097
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrew Rembrandt <andrew@rembrandt.dev>
+
+pkgname=plainmail2html-git
+_pkgname=plainmail2html
+pkgver=r28.3da0335
+pkgrel=1
+pkgdesc="Mutt utility to send HTML formatted Emails"
+arch=(any)
+url="https://github.com/amitramon/plainMail2HTML"
+license=('GPL')
+depends=("python-docutils")
+provides=("$_pkgname")
+source=("git+https://github.com/amitramon/${_pkgname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ find . -type f -not -path '*/.*' -not -path './bin/*' -exec sh -c \
+ 'install -m 644 -D "$0" '"$pkgdir"'/usr/share/'"${_pkgname}"'${0:1}' {} \;
+ find ./bin -type f -exec sh -c \
+ 'install -m 755 -D "$0" '"$pkgdir"'/usr/share/'"${_pkgname}"'${0:1}' {} \;
+
+ mkdir "$pkgdir/usr/bin"
+ find "$pkgdir/usr/share/${_pkgname}/bin/" -type f -exec sh -c \
+ 'ln -s "${0}" '"$pkgdir"'/usr/bin/$(basename ${0})' {} \;
+}