summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Andresen2017-09-29 13:48:23 +0200
committerBenjamin Andresen2017-09-29 13:51:08 +0200
commit166a825f7bff3c3c3efbcd6392b756b07d38ccf6 (patch)
treeb82752a1992615186acd837359308652289eb6dc
parent9d8d2685505527f6c118ad8c66952285b22715fe (diff)
downloadaur-166a825f7bff3c3c3efbcd6392b756b07d38ccf6.tar.gz
Add: $proj: include patch to fix segfault
with glibc 2.26 strtok behavior was changed and planck is depending on the old now obsolete behavior
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--fix-segfault-due-to-strtok-glibc-v2.26-change.patch15
3 files changed, 23 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5fb8b85c594..8ab90ae15458 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = planck
pkgdesc = A stand-alone ClojureScript REPL
pkgver = 2.7.3
- pkgrel = 2
+ pkgrel = 3
url = http://planck-repl.org/
arch = x86_64
license = EPL-1.0
@@ -15,7 +15,9 @@ pkgbase = planck
depends = zlib
conflicts = planck-git
source = https://github.com/mfikes/planck/archive/2.7.3.tar.gz
+ source = fix-segfault-due-to-strtok-glibc-v2.26-change.patch
sha256sums = 16a620c33bc15c2f74ce1e80726c55c85f634443c9675c0c08292a964eb01780
+ sha256sums = f081ac6cf76d98e5458716c2059d1174880e5daaba9ae3212b9df4713e3175e2
pkgname = planck
diff --git a/PKGBUILD b/PKGBUILD
index bca169ff79e3..1f2604b2c90a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='planck'
conflicts=('planck-git')
pkgver=2.7.3
-pkgrel=2
+pkgrel=3
_pkgnamever=${pkgname}-${pkgver}
pkgdesc="A stand-alone ClojureScript REPL"
arch=('x86_64')
@@ -13,11 +13,14 @@ makedepends=('java-environment' 'cmake' 'leiningen' 'unzip' 'vim')
license=('EPL-1.0')
source=(
https://github.com/mfikes/${pkgname}/archive/${pkgver}.tar.gz
+ fix-segfault-due-to-strtok-glibc-v2.26-change.patch
)
-sha256sums=('16a620c33bc15c2f74ce1e80726c55c85f634443c9675c0c08292a964eb01780')
+sha256sums=('16a620c33bc15c2f74ce1e80726c55c85f634443c9675c0c08292a964eb01780'
+ 'f081ac6cf76d98e5458716c2059d1174880e5daaba9ae3212b9df4713e3175e2')
build() {
cd "$srcdir/${_pkgnamever}"
+ patch -p1 -i ../fix-segfault-due-to-strtok-glibc-v2.26-change.patch
script/build
}
diff --git a/fix-segfault-due-to-strtok-glibc-v2.26-change.patch b/fix-segfault-due-to-strtok-glibc-v2.26-change.patch
new file mode 100644
index 000000000000..84f45e79958c
--- /dev/null
+++ b/fix-segfault-due-to-strtok-glibc-v2.26-change.patch
@@ -0,0 +1,15 @@
+diff --git a/planck-c/main.c b/planck-c/main.c
+index 4daaff9..9a3996d 100644
+--- a/planck-c/main.c
++++ b/planck-c/main.c
+@@ -506,7 +506,9 @@ int main(int argc, char **argv) {
+ }
+ }
+
+- init_classpath(classpath);
++ if (classpath) {
++ init_classpath(classpath);
++ }
+
+
+ if (config.num_src_paths == 0) {