summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:17:05 +0200
committerAlexander F Rødseth2015-06-10 15:17:05 +0200
commitd6335cee86ef5f841895112d92f2ca850a563b70 (patch)
treef74d4313470814fae8828e3227b118ee32ee2b00
downloadaur-planeshift.tar.gz
Initial import
-rw-r--r--.AURINFO25
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD100
-rw-r--r--license.txt22
-rw-r--r--planeshift.install32
-rw-r--r--planeshift_i686.meta416
-rw-r--r--planeshift_x86_64.meta416
-rw-r--r--scriptfix.patch20
8 files changed, 260 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..5028504f7ee6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,25 @@
+pkgbase = planeshift
+ pkgdesc = Open source and cross-platform 3D Fantasy MMORPG
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = http://www.planeshift.it/
+ install = planeshift.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ license = custom:PlaneShift Content License
+ makedepends = gendesk
+ makedepends = aria2
+ depends = libgl
+ depends = libsm
+ depends = libxmu
+ depends = libxpm
+ depends = openal
+ source = planeshift_x86_64.meta4
+ source = planeshift_i686.meta4
+ source = license.txt
+ source = scriptfix.patch
+ options = emptydirs
+
+pkgname = planeshift
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e4602fbe0d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = planeshift
+ pkgdesc = Open source and cross-platform 3D Fantasy MMORPG
+ pkgver = 0.6.3
+ pkgrel = 1
+ url = http://www.planeshift.it/
+ install = planeshift.install
+ arch = x86_64
+ arch = i686
+ license = GPL
+ license = custom:PlaneShift Content License
+ makedepends = gendesk
+ makedepends = aria2
+ depends = libgl
+ depends = libsm
+ depends = libxmu
+ depends = libxpm
+ depends = openal
+ options = emptydirs
+ source = planeshift_x86_64.meta4
+ source = planeshift_i686.meta4
+ source = license.txt
+ source = scriptfix.patch
+ sha256sums = 19daff9fd80bcf8a52cd4ce49af7509048083efa49d6efd5867c46e0e2b96073
+ sha256sums = 11aafef3fed081f42889124d393a8008c40e34a49abf16b94d7b49f1390dbab3
+ sha256sums = 51ba4271c77c00efe087f2f456ae777853f85b97767cf085d2fb8f9b82c082fc
+ sha256sums = b97231a4aa4b41ca1b5ca785086a02b61461d669db6561b580692ca6f3444a99
+
+pkgname = planeshift
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d65a47b1ad7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,100 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jakob Gruber <jakob.gruber@gmail.com>
+# Contributor: Marcelo Cavalcante / Kalib <kalib@archlinux-br.org>
+# Contributor: Matthias Maennich <arch@maennich.net>
+# Contributor: Andrea Scarpino <bash.lnx@gmail.com>
+# Contributor: Darwin Bautista <djclue917@gmail.com>
+# Contributor: Gimmeapill <gimmeapill@gmail.com>
+# Contributor: M Rawash <mrawash@gmail.com>
+
+pkgname=planeshift
+pkgver=0.6.3
+pkgrel=1
+pkgdesc='Open source and cross-platform 3D Fantasy MMORPG'
+url='http://www.planeshift.it/'
+arch=('x86_64' 'i686')
+license=('GPL' 'custom:PlaneShift Content License')
+depends=('libgl' 'libsm' 'libxmu' 'libxpm' 'openal')
+makedepends=('gendesk' 'aria2')
+options=('emptydirs')
+install="$pkgname.install"
+source=('planeshift_x86_64.meta4'
+ 'planeshift_i686.meta4'
+ 'license.txt'
+ 'scriptfix.patch')
+sha256sums=('19daff9fd80bcf8a52cd4ce49af7509048083efa49d6efd5867c46e0e2b96073'
+ '11aafef3fed081f42889124d393a8008c40e34a49abf16b94d7b49f1390dbab3'
+ '51ba4271c77c00efe087f2f456ae777853f85b97767cf085d2fb8f9b82c082fc'
+ 'b97231a4aa4b41ca1b5ca785086a02b61461d669db6561b580692ca6f3444a99')
+
+prepare() {
+ # Generate the .desktop file for the PlaneShift client
+ gendesk -f -n --pkgname "$pkgname" --pkgdesc "$pkgdesc" \
+ --name 'PlaneShift' --genericname 'MMORPG'
+
+ # Generate the .desktop file for the PlaneShift setup application
+ gendesk -f -n --pkgname 'pslaunch' -pkgdesc 'Configure PlaneShift' \
+ --name 'PlaneShift Launcher' --exec 'pslaunch' \
+ --categories='Application;Game'
+
+ # Download the binary (and warn about diskspace, since this seems to be a common problem)
+ msg2 "Downloading PlaneShift $pkgver (may seed for up to a minute)..."
+ msg2 "Be patient and don't panic!"
+ aria2c -M planeshift_$CARCH.meta4 -V -c --allow-overwrite=true \
+ --seed-ratio=5.0 --seed-time=1 --no-conf=true
+ if [ `find . -maxdepth 1 -name "PlaneShift-*.run" | wc -l` == 0 ]; then
+ msg2 'Download failed!'
+ echo
+ echo 'Make sure you have enough disk space in'
+ echo "$srcdir"
+ echo
+ echo 'You need at least 800-900 MB free for the download,'
+ echo 'and quite a bit more for extracting the file.'
+ echo
+ echo "Here's the currently available disk space:"
+ echo
+ df -h "$srcdir"
+ echo
+ return 1
+ fi
+}
+
+package() {
+ msg2 'Extracting...'
+ chmod +x PlaneShift-*$pkgver*.run
+ ./PlaneShift-*$pkgver*.run \
+ --mode unattended \
+ --syswide yes \
+ --prefix "$pkgdir/opt"
+
+ msg2 'Setting permissions...'
+ find "$pkgdir/opt/PlaneShift" -type f -exec chmod 660 {} +
+ find "$pkgdir/opt/PlaneShift" -type d -exec chmod 770 {} +
+ cd "$pkgdir/opt/PlaneShift"
+ chmod 770 psclient.bin pslaunch.bin psclient pslaunch
+
+ msg2 'Packaging scripts...'
+ install -Dm755 psclient "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 pslaunch "$pkgdir/usr/bin/pslaunch"
+
+ msg2 'Cleaning up...'
+ rm -f uninstall unscript.sh planeshift
+
+ msg2 'Patching...'
+ cd "$pkgdir/usr/bin/"
+ patch -Np0 < "$srcdir/scriptfix.patch"
+
+ msg2 'Packaging shortcuts...'
+ mkdir -p "$pkgdir/usr/share/applications"
+ install -Dm644 "$srcdir"/*.desktop "$pkgdir/usr/share/applications/"
+ install -Dm644 "$pkgdir/opt/PlaneShift/support/icons/crystal.png" \
+ "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "$pkgdir/opt/PlaneShift/support/icons/psicon.png" \
+ "$pkgdir/usr/share/pixmaps/pslaunch.png"
+
+ msg2 'Packaging license...'
+ install -Dm644 "$srcdir/license.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..fd3df125db08
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,22 @@
+TERMS AND CONDITIONS FOR USAGE, COPYING, DISTRIBUTION AND MODIFICATION
+
+0. This License applies to any material or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this PlaneShift Content License.
+
+1. Terms defined in this Article 1, and parenthetically elsewhere, shall throughout this License have the meanings here and there provided. Defined terms may be used in the singular or plural. Definitions:
+
+• The "Material", below, refers to any such material or work, and a "work based on the Material" means either the Material or any Derivative Work under copyright law.
+• "Derivative Work" shall mean a work containing the Material or a portion of it, such as a revision, modification, enhancement, adaptation, translation (including compilation or recompilation by computer), abridgement, condensation, expansion, or any other form in which such preexisting works may be recast, transformed, or adapted, and that, if prepared without authorization of the owner of the copyright in such preexisting work, would constitute a copyright infringement.
+• Each licensee is addressed as "you".
+• "Official PlaneShift Server" is defined as a server name and ip address. Official PlaneShift Servers are defined by Atomic Blue and published on the site http://www.planeshift.it. No other server, except the ones listed at that web site, can be considered an Official PlaneShift Server.
+
+2. You may not copy, modify, publish, transmit, sell, participate in the transfer or sale or reproduce, create Derivative Works from, distribute, perform, display or in any way exploit any of the Material released under this License unless expressly permitted by the Atomic Blue.
+
+3. You may use the provided Material, for personal use only, to connect to an Official PlaneShift Server only in conjunction with a Planeshift Client, distributed by Atomic Blue. Official PlaneShift Servers can only be designated by Atomic Blue.
+
+NO WARRANTY
+
+4. THERE IS NO WARRANTY FOR THE MATERIAL PROVIDED, TO THE EXTENT PERMITTED BY APPLICABLE LAW. THE MATERIAL IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE MATERIAL IS WITH YOU.
+
+5. IN NO EVENT SHALL ATOMIC BLUE BE LIABLE FOR ANY DAMAGES WHATSOEVER, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE MATERIAL.
+
+END OF TERMS AND CONDITIONS
diff --git a/planeshift.install b/planeshift.install
new file mode 100644
index 000000000000..fd51ed7b12b5
--- /dev/null
+++ b/planeshift.install
@@ -0,0 +1,32 @@
+
+post_install() {
+ cat << EOF
+==>
+==> To be able to play, save configs, and update PlaneShift,
+==> add your user to the games group:
+==> # gpasswd -a USERNAME games
+EOF
+ post_upgrade
+}
+
+post_upgrade() {
+ cat << EOF
+==>
+==> Updating PlaneShift before running it is recommended.
+==>
+==> If the fonts are garbled or ugly, try doing this:
+==> Open up /opt/PlaneShift/data/config/r3dopengl.cfg in
+==> a text editor and find this line:
+==>
+==> Video.OpenGL.FontCache.UseMultiTexturing = yes
+==>
+==> Then change 'yes' to 'no'.
+==>
+EOF
+}
+
+op=$1
+shift
+[ "$(type -t "$op")" = "function" ] && $op "$@"
+
+# vim:set ts=2 sw=2 et:
diff --git a/planeshift_i686.meta4 b/planeshift_i686.meta4
new file mode 100644
index 000000000000..c132a3aec27b
--- /dev/null
+++ b/planeshift_i686.meta4
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<metalink xmlns="urn:ietf:params:xml:ns:metalink">
+ <published>2014-01-03T22:15:00Z</published>
+ <file name="PlaneShift-v0.6.3-x86.run">
+ <version>0.6.3</version>
+ <description>
+ PlaneShift 0.6.3 for 32-bit Linux
+ </description>
+ <hash type="md5">ba9500f83b15aea19bdbe2491d538ca2</hash>
+ <url location="fr" priority="1">http://mirror.osmmo.org/planeshift/PlaneShift-v0.6.3-x86.run</url>
+ <url location="de" priority="1">http://kiwi.frubar.net/planeshift/PlaneShift-v0.6.3-x86.run</url>
+ <url location="de" priority="1">http://mirroring.psde.de/PlaneShift-v0.6.3-x86.run</url>
+ <url location="us" priority="1">http://mirrors.redlem.com/PlaneShift/PlaneShift-v0.6.3-x86.run</url>
+ <metaurl mediatype="torrent" priority="2">http://194.116.72.94/bt/PlaneShift-v0.6.3-x86.run.torrent</metaurl>
+ </file>
+</metalink>
diff --git a/planeshift_x86_64.meta4 b/planeshift_x86_64.meta4
new file mode 100644
index 000000000000..1cf45fa8a75c
--- /dev/null
+++ b/planeshift_x86_64.meta4
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<metalink xmlns="urn:ietf:params:xml:ns:metalink">
+ <published>2014-01-03T22:15:00Z</published>
+ <file name="PlaneShift-v0.6.3-x64.run">
+ <version>0.6.3</version>
+ <description>
+ PlaneShift 0.6.3 for 64-bit Linux
+ </description>
+ <hash type="md5">a35cc411a44f52edefc99cad5425d60b</hash>
+ <url location="fr" priority="1">http://mirror.osmmo.org/planeshift/PlaneShift-v0.6.3-x64.run</url>
+ <url location="de" priority="1">http://kiwi.frubar.net/planeshift/PlaneShift-v0.6.3-x64.run</url>
+ <url location="de" priority="1">http://mirroring.psde.de/PlaneShift-v0.6.3-x64.run</url>
+ <url location="us" priority="1">http://mirrors.redlem.com/PlaneShift/PlaneShift-v0.6.3-x64.run</url>
+ <metaurl mediatype="torrent" priority="2">http://194.116.72.94/bt/PlaneShift-v0.6.3-x64.run.torrent</metaurl>
+ </file>
+</metalink>
diff --git a/scriptfix.patch b/scriptfix.patch
new file mode 100644
index 000000000000..336cca491319
--- /dev/null
+++ b/scriptfix.patch
@@ -0,0 +1,20 @@
+--- planeshift~ 2008-07-10 20:04:22.000000000 +0200
++++ planeshift 2008-07-10 20:04:53.000000000 +0200
+@@ -1,6 +1,6 @@
+ #!/bin/bash
+
+-cd $(dirname $0)
++cd /opt/PlaneShift
+ export LD_LIBRARY_PATH=libs/:$LD_LIBRARY_PATH
+ exec ./psclient.bin $@
+
+--- pslaunch~~ 2008-07-10 20:05:19.000000000 +0200
++++ pslaunch 2008-07-10 20:05:32.000000000 +0200
+@@ -1,6 +1,6 @@
+ #!/bin/bash
+
+-cd $(dirname $0)
++cd /opt/PlaneShift
+ export LD_LIBRARY_PATH=libs/:$LD_LIBRARY_PATH
+ exec ./pslaunch.bin $@
+