summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 02:46:46 -0300
committerHugo Osvaldo Barrera2015-06-09 02:47:32 -0300
commit98f498f265276b16729b424592d13681a7b4104b (patch)
treefeeef88db791d5e3f0aac00ce73e7cbc1920be42
downloadaur-98f498f265276b16729b424592d13681a7b4104b.tar.gz
Initial commit.
-rw-r--r--.SRCINFO32
-rw-r--r--PA.desktop10
-rw-r--r--PA.pngbin0 -> 5972 bytes
-rw-r--r--PA.sh3
-rw-r--r--PKGBUILD61
-rw-r--r--content.json586
-rw-r--r--uifix.js18
7 files changed, 710 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a43d0cc3f9b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = planetary-annihilation
+ pkgdesc = RTS gameplay in a way that's never been seen before.
+ pkgver = 76766
+ pkgrel = 1
+ url = http://www.uberent.com/pa/
+ arch = x86_64
+ license = custom
+ depends = alsa-lib
+ depends = gconf
+ depends = nss
+ depends = gtk2
+ depends = libtxc_dxtn
+ depends = rtmpdump
+ conflicts = planetary-annihilation-pte
+ noextract = PA_Linux_76766.tar.bz2
+ options = !libtool
+ options = !strip
+ source = PA_Linux_76766.tar.bz2::https://manual-download-required
+ source = PA.desktop
+ source = PA.png
+ source = content.json
+ source = uifix.js
+ source = PA.sh
+ md5sums = 3e425249efda33574bc67b677cb1de9b
+ md5sums = 16b2acc35fe4cd6fa06aff57b4a6fdc4
+ md5sums = 463f4e99f44ff6ce9c09e383767a6b1d
+ md5sums = d77de6676e68c1c355fe858a0522cae0
+ md5sums = f37053bfa07d40911c0c0a4404a54614
+ md5sums = 2f62773702cc5fcee03b160296738b29
+
+pkgname = planetary-annihilation
+
diff --git a/PA.desktop b/PA.desktop
new file mode 100644
index 000000000000..5f49786ab24d
--- /dev/null
+++ b/PA.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Planetary Annihilation
+GenericName=Strategy Game
+Comment=Total Annihilation-inspired game on a planetary scale
+Icon=PA
+Exec=/opt/PA/PA
+Path=/opt/PA
+Categories=Game;StrategyGame;
diff --git a/PA.png b/PA.png
new file mode 100644
index 000000000000..64a92ce23ef6
--- /dev/null
+++ b/PA.png
Binary files differ
diff --git a/PA.sh b/PA.sh
new file mode 100644
index 000000000000..a903236a7c6f
--- /dev/null
+++ b/PA.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /opt/PA
+./PA --software-ui
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2079bc87e7a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+# Contributor: Dmitrij D. Czarkoff <czarkoff@gmail.com>
+# Contributor: Swift Geek
+
+# Please note you'll need to download the Linux tar.bz2 in order for this
+# PKGBUILD to work, since PA is propietary software.
+# https://store.uberent.com/download/pa
+
+pkgname=planetary-annihilation
+pkgver=76766
+pkgrel=1
+pkgdesc="RTS gameplay in a way that's never been seen before."
+group=("games")
+arch=("x86_64")
+url="http://www.uberent.com/pa/"
+license=("custom")
+depends=("alsa-lib" "gconf" "nss" "gtk2" "libtxc_dxtn" "rtmpdump")
+conflicts=("planetary-annihilation-pte")
+options=("!libtool" "!strip")
+source=(PA_Linux_${pkgver}.tar.bz2::https://manual-download-required
+ PA.desktop
+ PA.png
+ content.json
+ uifix.js
+ PA.sh)
+noextract=(PA_Linux_${pkgver}.tar.bz2)
+PKGEXT=".pkg.tar"
+
+package() {
+ # Game itself
+ install -d "${pkgdir}/opt/"
+ tar xf "${srcdir}/PA_Linux_${pkgver}.tar.bz2" -C "${pkgdir}/opt/"
+ find "$pkgdir/opt/PA" -type f -exec chmod -R u+w,go-w {} \;
+ chown -R root:root "$pkgdir/opt/PA"
+
+ # License
+ install -Dm 644 "${pkgdir}/opt/PA/licenses.txt" "${pkgdir}/usr/share/licenses/$pkgname/licenses.txt"
+
+ # Launcher script
+ install -Dm 755 "${srcdir}/PA.sh" "${pkgdir}/usr/bin/PA"
+
+ # DE Launcher icon
+ mkdir -p "$pkgdir/opt" "$pkgdir/usr/share/applications" \
+ "$pkgdir/usr/share/icons"
+ install -m644 "$srcdir/PA.desktop" "$pkgdir/usr/share/applications"
+ install -m644 "$srcdir/PA.png" "$pkgdir/usr/share/icons"
+
+ ### QUIRKS ###
+ cd "$pkgdir/opt/PA"
+
+ # Workaround for "black screen" issue
+ rm media/shaders/content.json
+ install -m644 "$srcdir/content.json" media/shaders
+}
+
+md5sums=('3e425249efda33574bc67b677cb1de9b'
+ '16b2acc35fe4cd6fa06aff57b4a6fdc4'
+ '463f4e99f44ff6ce9c09e383767a6b1d'
+ 'd77de6676e68c1c355fe858a0522cae0'
+ 'f37053bfa07d40911c0c0a4404a54614'
+ '2f62773702cc5fcee03b160296738b29')
diff --git a/content.json b/content.json
new file mode 100644
index 000000000000..ca48974e2990
--- /dev/null
+++ b/content.json
@@ -0,0 +1,586 @@
+{
+ "effects":[
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"solid",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"solid.fs",
+ "vertex":"position_normal.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"skinned_solid",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"solid.fs",
+ "vertex":"skinned_4bone.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"vertex_lit",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"vertex_lit.fs",
+ "vertex":"position_color_normal.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"vertex_lit_transparent",
+ "techniques":[
+ {
+ "blend":{
+ "dest":"inv_src_alpha",
+ "enabled":true,
+ "op":"add",
+ "source":"src_alpha"
+ },
+ "name":"Default",
+ "pixel":"vertex_lit.fs",
+ "vertex":"position_color_normal_uv_lit.vs"
+ }
+ ],
+ "transparent":true,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":false,
+ "name":"vertex_unlit",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"vertex_color_unlit.fs",
+ "vertex":"position_color.vs"
+ },
+ {
+ "name":"RenderVTPage",
+ "pixel":"vt_renderpage_color.fs",
+ "vertex":"vt_renderpage_color.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"planet_liquid_transparent",
+ "techniques":[
+ {
+ "blend":{
+ "dest":"inv_src_alpha",
+ "enabled":true,
+ "op":"add",
+ "source":"src_alpha"
+ },
+ "depth":{
+ "compare":"less",
+ "read":true,
+ "write":false
+ },
+ "name":"Default",
+ "pixel":"liquid_flow.fs",
+ "vertex":"liquid_flow.vs"
+ }
+ ],
+ "transparent":true,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"skinned_textured",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"skinned_4bone.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"pa_unit",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap.vs"
+ },
+ {
+ "name":"ShadowMapBatch",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_batch.vs"
+ },
+ {
+ "name":"ShadowMapBatchIndex",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_batch_index.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit.fs",
+ "vertex":"prelight_flat.vs"
+ },
+ {
+ "name":"PrelightBatch",
+ "pixel":"prelight_pa_unit.fs",
+ "vertex":"prelight_flat_batch.vs"
+ },
+ {
+ "name":"PrelightBatchIndex",
+ "pixel":"prelight_pa_unit.fs",
+ "vertex":"prelight_flat_batch_index.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"skinned_pa_unit",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"skinned_4bone.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_skinned_4bone.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit.fs",
+ "vertex":"prelight_skinned_4bone.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"pa_unit_fab",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap.vs"
+ },
+ {
+ "name":"ShadowMapBatch",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_batch.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit_fab.fs",
+ "vertex":"prelight_flat_fab.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"skinned_pa_unit_fab",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"skinned_4bone.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap_pa_unit_fab.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_skinned_4bone_tex.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit_fab.fs",
+ "vertex":"prelight_skinned_4bone_fab.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"pa_unit_dead",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap.vs"
+ },
+ {
+ "name":"ShadowMapBatch",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_batch.vs"
+ },
+ {
+ "name":"ShadowMapBatchIndex",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_batch_index.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit_dead.fs",
+ "vertex":"prelight_flat.vs"
+ },
+ {
+ "name":"PrelightBatch",
+ "pixel":"prelight_pa_unit_dead.fs",
+ "vertex":"prelight_flat_batch.vs"
+ },
+ {
+ "name":"PrelightBatchIndex",
+ "pixel":"prelight_pa_unit_dead.fs",
+ "vertex":"prelight_flat_batch_index.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"skinned_pa_unit_dead",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"skinned_4bone.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_pa_unit_dead.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit_dead.fs",
+ "vertex":"prelight_skinned_4bone_dead.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"pa_unit_ghost",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap_pa_unit_ghost.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_tex.vs"
+ },
+ {
+ "name":"ShadowMapBatch",
+ "pixel":"shadowmap_pa_unit_ghost.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_tex_batch.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit_ghost.fs",
+ "vertex":"prelight_flat.vs"
+ },
+ {
+ "name":"PrelightBatch",
+ "pixel":"prelight_pa_unit_ghost.fs",
+ "vertex":"prelight_flat_batch.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"skinned_pa_unit_ghost",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"skinned_4bone.vs"
+ },
+ {
+ "name":"ShadowMap",
+ "pixel":"shadowmap_pa_unit_ghost.fs",
+ "rast":{
+ "cullmode":"front",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"shadowmap_skinned_4bone_tex.vs"
+ },
+ {
+ "name":"Prelight",
+ "pixel":"prelight_pa_unit_ghost.fs",
+ "vertex":"prelight_skinned_4bone.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"textured",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"Normals",
+ "pixel":"textured.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"LightOnly",
+ "pixel":"light_only.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"DiffuseLightOnly",
+ "pixel":"diffuse_light_only.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"SpecularLightOnly",
+ "pixel":"specular_light_only.fs",
+ "vertex":"position_normal_uv.vs"
+ },
+ {
+ "name":"RenderVTPage",
+ "pixel":"vt_renderpage_flat.fs",
+ "rast":{
+ "cullmode":"none",
+ "solid":true,
+ "write_alpha":true,
+ "write_blue":true,
+ "write_green":true,
+ "write_red":true
+ },
+ "vertex":"vt_renderpage.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"textured_normal",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured_normal.fs",
+ "vertex":"position_tangent_uv.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"planet",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured_normal.fs",
+ "vertex":"position_tangent_uv.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":true,
+ "name":"textured_normal_material",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"textured_normal.fs",
+ "vertex":"position_tangent_uv.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ },
+ {
+ "hdr":true,
+ "lit":false,
+ "name":"sun",
+ "techniques":[
+ {
+ "name":"Default",
+ "pixel":"sun.fs",
+ "vertex":"sun.vs"
+ }
+ ],
+ "transparent":false,
+ "virtual_textured":false
+ }
+ ]
+} \ No newline at end of file
diff --git a/uifix.js b/uifix.js
new file mode 100644
index 000000000000..a07501445611
--- /dev/null
+++ b/uifix.js
@@ -0,0 +1,18 @@
+
+var DEBUG_HOST = "127.0.0.1";
+var DEBUG_PORT = 9999
+
+$(function()
+{
+ $.getJSON(
+ "http://" + DEBUG_HOST + ":" + DEBUG_PORT + "/json",
+ function(data)
+ {
+ $.each(data, function(index, view)
+ {
+ var url = view["webSocketDebuggerUrl"];
+ var socket = new WebSocket(url);
+ socket.onopen = function() { socket.close(); }
+ });
+ });
+});