summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-09 02:39:07 -0300
committerHugo Osvaldo Barrera2015-06-09 02:39:27 -0300
commit718baab3e1ea79a3d3e141ca0fe5a437dfcca7e0 (patch)
treebfba0f161937422c3aa83b56e73457cb75de3ca8
downloadaur-718baab3e1ea79a3d3e141ca0fe5a437dfcca7e0.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PA.sh7
-rw-r--r--PKGBUILD26
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c38d0f574400
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = planetary-annihilation-pte
+ pkgdesc = Planetary Annihilation Public Test Environment Launcher
+ pkgver = latest
+ pkgrel = 3
+ url = https://forums.uberent.com/threads/streams-pte-and-experimental-builds.58960/page-4#post-937028
+ arch = x86_64
+ license = MIT
+ depends = python-pycurl
+ conflicts = planetary-annihilation
+ source = git+ssh://git@github.com/pa-pyrus/papatcher.git
+ source = PA.sh
+ md5sums = SKIP
+ md5sums = a06eed75eb032d8a03b25d92b8abebd1
+
+pkgname = planetary-annihilation-pte
+
diff --git a/PA.sh b/PA.sh
new file mode 100644
index 000000000000..1bf2bdc7bd65
--- /dev/null
+++ b/PA.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+if [ ! -x $HOME/.local/Uber\ Entertainment/PA/PTE/PA ]; then
+ echo Please run PA-pte to download the PTE build of the game first.
+else
+ exec $HOME/.local/Uber\ Entertainment/PA/PTE/PA
+fi;
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c31cc3cc5be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Hugo Osvaldo Barrera <hugo@barrera.io>
+
+pkgname=planetary-annihilation-pte
+pkgver=latest
+pkgrel=3
+pkgdesc="Planetary Annihilation Public Test Environment Launcher"
+group=("games")
+arch=('x86_64')
+url="https://forums.uberent.com/threads/streams-pte-and-experimental-builds.58960/page-4#post-937028"
+license=('MIT')
+depends=("python-pycurl")
+conflicts=("planetary-annihilation")
+source=("git+ssh://git@github.com/pa-pyrus/papatcher.git"
+ "PA.sh")
+md5sums=('SKIP'
+ 'a06eed75eb032d8a03b25d92b8abebd1')
+
+pkgver() {
+ cd "$srcdir/${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ install -Dm 755 "$srcdir/papatcher/papatcher.py" "$pkgdir/usr/bin/PA-pte"
+ install -Dm 755 "${srcdir}/PA.sh" "${pkgdir}/usr/bin/PA"
+}