summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSven Klomp2016-03-05 18:32:17 +0100
committerSven Klomp2016-03-05 18:32:17 +0100
commit7a1eb621a74192b4b3518de40c6a65dc0bb3ac80 (patch)
tree582c8bf14f1cd74cf08423873b28791e07df7a8e
downloadaur-7a1eb621a74192b4b3518de40c6a65dc0bb3ac80.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD47
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..12a70800d245
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Sat Mar 5 17:32:00 UTC 2016
+pkgbase = planeworld-git
+ pkgdesc = 2D physics simulation
+ pkgver = 0.306.db2642c
+ pkgrel = 1
+ url = http://planeworld.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gcc-libs
+ makedepends = git
+ makedepends = cmake
+ makedepends = pugixml
+ makedepends = sfml
+ makedepends = lua
+ makedepends = libnoise2d
+ depends = pugixml
+ depends = sfml
+ depends = lua
+ depends = libnoise2d
+ provides = planeworld=0.0.1
+ source = git+https://github.com/planeworld/planeworld.git
+ md5sums = SKIP
+
+pkgname = planeworld-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57b10ad8fb05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Package build for planeworld from git (https://github.com/planeworld/planeworld)
+# Maintainer: Sven Klomp <mail at klomp dot eu>
+
+pkgdesc='2D physics simulation'
+_gitname=('planeworld')
+pkgname=('planeworld-git')
+provides=('planeworld=0.0.1')
+pkgver=0.306.db2642c
+pkgrel=1
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://planeworld.org/"
+depends=('pugixml' 'sfml' 'lua' 'libnoise2d')
+makedepends=('gcc-libs' 'git' 'cmake' 'pugixml' 'sfml' 'lua' 'libnoise2d')
+source=("git+https://github.com/planeworld/planeworld.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/${_gitname}
+ echo "0.$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+
+prepare() {
+ cd "${srcdir}/${_gitname}"
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+
+ if [ ! -d "${srcdir}/build" ]; then
+ mkdir -p "${srcdir}/build"
+ fi
+
+ cd "${srcdir}/build"
+
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr "../${_gitname}"
+
+ make
+
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+
+}