summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime Gauduin2015-06-08 11:11:06 +0200
committerMaxime Gauduin2015-06-08 11:11:06 +0200
commitcb28b2deaab8e8e1cdaee11f4030f5aa731386cb (patch)
treead988b29196c3fdce1fae91cfbc294133d22af7c
downloadaur-cb28b2deaab8e8e1cdaee11f4030f5aa731386cb.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD42
-rw-r--r--plank.install13
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fff4a2dfe793
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = plank-bzr
+ pkgdesc = Elegant, simple, clean dock
+ pkgver = r1018
+ pkgrel = 1
+ url = https://launchpad.net/plank
+ install = plank.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = bzr
+ makedepends = gnome-common
+ makedepends = intltool
+ makedepends = vala
+ depends = bamf
+ depends = libdbusmenu-gtk3
+ depends = libgee
+ provides = plank
+ conflicts = plank
+ source = bzr+lp:plank
+ sha256sums = SKIP
+
+pkgname = plank-bzr
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..a4c06114f4d5
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('plank-bzr')
+
+check_bzr $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44196b918b47
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+# Contributor: Ner0 <darkelfdarkelf666@yahoo.co.uk>
+# Contributor: dcelasun <dcelasun@gmail.com>
+
+pkgname=plank-bzr
+pkgver=r1018
+pkgrel=1
+pkgdesc='Elegant, simple, clean dock'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/plank'
+license=('GPL3')
+depends=('bamf' 'libdbusmenu-gtk3' 'libgee')
+makedepends=('bzr' 'gnome-common' 'intltool' 'vala')
+provides=('plank')
+conflicts=('plank')
+install='plank.install'
+source=('bzr+lp:plank')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd plank
+
+ printf "r%s" "$(bzr revno)"
+}
+
+build() {
+ cd plank
+
+ ./autogen.sh \
+ --prefix='/usr' \
+ --sysconfdir='/etc' \
+ --disable-apport
+ make
+}
+
+package() {
+ cd plank
+
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/plank.install b/plank.install
new file mode 100644
index 000000000000..44851fff35c3
--- /dev/null
+++ b/plank.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -ftq /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim: ts=2 sw=2 et: