summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike McQueen2021-08-18 18:51:23 -0700
committerMike McQueen2021-08-18 18:51:23 -0700
commit9b43f6b166fc24d74c0123b0891bd896172141f7 (patch)
tree886b3fd7d57ab68d61ddd163df52a5d6efc13c58
downloadaur-9b43f6b166fc24d74c0123b0891bd896172141f7.tar.gz
first commit
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD37
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2f25c302cdf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = plank-theme-hope
+ pkgdesc = Collection of Hope Edition Themes for Plank
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://www.pling.com/p/1301622/
+ arch = any
+ license = CC-BY-SA
+ source = https://github.com/MMcQueenGNU/plank-theme-hope/archive/refs/tags/v1.0.1.tar.gz
+ sha256sums = f3c5c7229afa4ab6b9e2f4dd73e850b054728ce0fcb7921171017bad46104d11
+
+pkgname = plank-theme-hope
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0ccbe8437e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: McQueen <clear3239@yahoo.com>
+_pkgname=hope-cool
+_pkgname2=hope-extend
+_pkgname3=hope-original
+_pkgname4=hope-slim
+pkgname=plank-theme-hope
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Collection of Hope Edition Themes for Plank'
+arch=(any)
+url='https://www.pling.com/p/1301622/'
+_url="https://github.com/MMcQueenGNU"
+license=('CC-BY-SA')
+source=("$_url/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+
+sha256sums=('f3c5c7229afa4ab6b9e2f4dd73e850b054728ce0fcb7921171017bad46104d11')
+
+build() {
+ true
+}
+
+package() {
+
+ mkdir -p $pkgdir/usr/share/plank/themes/$_pkgname
+ mkdir -p $pkgdir/usr/share/plank/themes/$_pkgname2
+ mkdir -p $pkgdir/usr/share/plank/themes/$_pkgname3
+ mkdir -p $pkgdir/usr/share/plank/themes/$_pkgname4
+ cd "$srcdir/$pkgname-$pkgver/$_pkgname"
+ install -m 755 dock.theme $pkgdir/usr/share/plank/themes/$_pkgname/
+ cd "$srcdir/$pkgname-$pkgver/$_pkgname2"
+ install -m 755 dock.theme $pkgdir/usr/share/plank/themes/$_pkgname2/
+ cd "$srcdir/$pkgname-$pkgver/$_pkgname3"
+ install -m 755 dock.theme $pkgdir/usr/share/plank/themes/$_pkgname3/
+ cd "$srcdir/$pkgname-$pkgver/$_pkgname4"
+ install -m 755 dock.theme $pkgdir/usr/share/plank/themes/$_pkgname4/
+}
+