summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzzy2021-03-19 13:03:39 +0800
committerzzy2021-03-19 13:03:39 +0800
commit432c2a0762b70519b57e02269fdede8f471cefa2 (patch)
tree10f19f9122cb64cb2c7a1c2ff2d32dd08af4d4a7
downloadaur-432c2a0762b70519b57e02269fdede8f471cefa2.tar.gz
Example
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2450f49b71f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plantsvszombies
+ pkgdesc = plantsvszombies by deepin-wine5
+ pkgver = 1.1
+ pkgrel = 1
+ arch = x86_64
+ license = GPL
+ depends = deepin-wine5
+ depends = deepin-wine5-helper
+ provides = plantsvszombies=1.1
+ source = https://hub.fastgit.org/zzy-ac/plantsvszombies/raw/master/plantsvszombies.tar.gz
+ md5sums = SKIP
+
+pkgname = plantsvszombies
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0dbca2d0636
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: zzy-ac <1304024859@qq.com>
+pkgname=plantsvszombies
+pkgver=1.1
+pkgrel=1
+pkgdesc="plantsvszombies by deepin-wine5"
+arch=(x86_64)
+url=""
+license=('GPL')
+depends=('deepin-wine5' 'deepin-wine5-helper')
+provides=(plantsvszombies=$pkgver)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://hub.fastgit.org/zzy-ac/plantsvszombies/raw/master/plantsvszombies.tar.gz")
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+prepare() {
+ mkdir "$pkgname-$pkgver"
+ cp -r opt "$pkgname-$pkgver"/opt
+ cp -r usr "$pkgname-$pkgver"/usr
+}
+
+#check() {
+# cd "$pkgname-$pkgver"
+# make -k check
+#}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cp -r opt ${pkgdir}
+ cp -r usr ${pkgdir}
+}
+
+