summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGFdevelop2020-12-19 21:05:19 +0100
committerGFdevelop2020-12-19 21:05:19 +0100
commit972e38def0685255773371fbd22da1b52069f2d9 (patch)
tree5df0a86a1ac8d4c8425df38a942d66954002d4b5
parent2d457d4ca736c9617c5d31241e446d300dfeb652 (diff)
downloadaur-972e38def0685255773371fbd22da1b52069f2d9.tar.gz
update to 3.4.2
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md85
-rw-r--r--PKGBUILD6
3 files changed, 77 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d99a7cfd4ac5..fd4dd38a7ac6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = plantuml-markdown
pkgdesc = PlantUML plugin for Python-Markdown
- pkgver = 3.2.2
- pkgrel = 2
+ pkgver = 3.4.2
+ pkgrel = 1
url = https://github.com/mikitex70/plantuml-markdown
changelog = CHANGELOG.md
arch = any
@@ -13,8 +13,8 @@ pkgbase = plantuml-markdown
depends = python-markdown
depends = plantuml
depends = python-plantuml-git
- source = plantuml-markdown-3.2.2.tar.gz::https://github.com/mikitex70/plantuml-markdown/archive/3.2.2.tar.gz
- md5sums = a6657de22cb14b53bb39ef1261f89085
+ source = plantuml-markdown-3.4.2.tar.gz::https://github.com/mikitex70/plantuml-markdown/archive/3.4.2.tar.gz
+ md5sums = 7fbbe263f1e1cc3628237dc37e90b0cf
pkgname = plantuml-markdown
diff --git a/CHANGELOG.md b/CHANGELOG.md
index d2dc05352e2d..02c8a990d0fd 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,7 +1,76 @@
# Changelog
-## development (2020-03-04)
+## 3.4.2 (2020-12-19)
+
+### Changes
+
+* Remove tests for python < 3.6. [Michele Tessaro]
+
+ Python versions before 3.6 are now at end of life.
+ `plantuml-markdown` will not be tested with those versions, and bugs
+ will be fixed only if reproducible with more recent Python versions.
+
+### Fix
+
+* Fixed working with Markdown 3.3 (fixes #39) [Michele Tessaro]
+
+* Fixed indentation handling (fixes #51) [Michele Tessaro]
+
+
+## 3.4.1 (2020-10-28)
+
+### Fix
+
+* Fixed multiple mixed code blocks (fixes #45) [Michele Tessaro]
+
+ Fixed parsing of mixed `fenced_code` and `plantuml_markdown` blocks in
+ the same document.
+
+
+## 3.4.0 (2020-08-23)
+
+### New
+
+* Capability to keep both inline and source data (implements #47) [Ihsan Topaloglu]
+
+ As per discussed on https://github.com/mikitex70/plantuml-markdown/issues/47
+
+### Changes
+
+* Updated CHANGELOG.md. [Michele Tessaro]
+
+* Update README.md (refs #47) [Ihsan Topaloglu]
+
+* Update README.md (refs #47) [Ihsan Topaloglu]
+
+ Readme update for the `source` inclusion feature that came with https://github.com/mikitex70/plantuml-markdown/releases/tag/3.3.0
+
+### Fix
+
+* Fixed uml code inside fenced code (fixes #45) [Michele Tessaro]
+
+ UML source diagram inside a fenced code is now leaved untouched.
+
+
+## 3.3.0 (2020-06-18)
+
+### New
+
+* Added support for loading plantuml from external files (refs #42) [Chalmela, Ravi]
+
+### Changes
+
+* Updated documentation. [Michele Tessaro]
+
+* Updated documentation. [Michele Tessaro]
+
+### Fix
+
+* Fixed closing of object tag (fixes #44) [Michele Tessaro]
+
+
+## 3.2.2 (2020-03-04)
### Fix
@@ -51,10 +120,6 @@
## 3.1.3 (2019-08-26)
-### New
-
-* Added a test for issue #31. [Michele Tessaro]
-
### Changes
* Updated changelog for the new release. [Michele Tessaro]
@@ -97,10 +162,6 @@
## 3.1.1 (2019-05-29)
-### New
-
-* Configured travis to test with multiple Markdown versions. [Michele Tessaro]
-
### Fix
* Fixed compatibility with Markdown 2 (refs #29) [Michele Tessaro]
@@ -144,10 +205,6 @@
## 2.0.2 (2019-03-16)
-### New
-
-* Added test to verify utf-8 character handling. [Michele Tessaro]
-
### Changes
* Updated documentation for new release. [Michele Tessaro]
@@ -167,8 +224,6 @@
* Fixed package contents. [Michele Tessaro]
-* Fixed travis configuration. [Michele Tessaro]
-
## 2.0.0 (2019-03-02)
diff --git a/PKGBUILD b/PKGBUILD
index c7fc85a6dcc4..ef28147164a1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Gabriele Fulgaro <gabriele.fulgaro@gmail.com>
pkgname=plantuml-markdown
-pkgver=3.2.2
-pkgrel=2
+pkgver=3.4.2
+pkgrel=1
pkgdesc="PlantUML plugin for Python-Markdown"
arch=('any')
url="https://github.com/mikitex70/${pkgname}"
@@ -12,7 +12,7 @@ makedepends=('python-setuptools')
checkdepends=('pymdown-extensions' 'python-mock' 'python-nose2')
changelog="CHANGELOG.md" # https://raw.githubusercontent.com/mikitex70/plantuml-markdown/master/CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::${url}/archive/${pkgver}.tar.gz")
-md5sums=('a6657de22cb14b53bb39ef1261f89085')
+md5sums=('7fbbe263f1e1cc3628237dc37e90b0cf')
build() {
cd "$pkgname-$pkgver"