summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorАлексей Мальченко2017-08-01 13:14:50 +0400
committerАлексей Мальченко2017-08-01 13:14:50 +0400
commitee2fd5b601bd96df18aded4951fe2f3a4dc4c676 (patch)
tree7c6e9ef2429f8e2513fafa838d33b79285a94f83
downloadaur-ee2fd5b601bd96df18aded4951fe2f3a4dc4c676.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rw-r--r--plantumlqeditor-git.install36
3 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab3659ede41d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Aug 1 09:14:35 UTC 2017
+pkgbase = plantumlqeditor-git
+ pkgdesc = PlantUML QEditor is a simple editor written in Qt5 for PlantUML
+ pkgver = 2.1_20170801
+ pkgrel = 1
+ url = https://github.com/jalbersol/plantumlqeditor
+ install = plantumlqeditor-git.install
+ arch = any
+ license = GPL3
+ depends = plantuml
+ depends = qt5-base
+ depends = graphviz
+ source = git+https://github.com/jalbersol/plantumlqeditor.git
+ md5sums = SKIP
+
+pkgname = plantumlqeditor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f153da047571
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alexey <pozitiffcat2@gmail.com>
+
+pkgname='plantumlqeditor-git'
+pkgver='2.1_20170801'
+pkgrel=1
+pkgdesc='PlantUML QEditor is a simple editor written in Qt5 for PlantUML'
+arch=('any')
+url='https://github.com/jalbersol/plantumlqeditor'
+license=('GPL3')
+depends=('plantuml' 'qt5-base' 'graphviz')
+source=('git+https://github.com/jalbersol/plantumlqeditor.git')
+md5sums=('SKIP')
+install="$pkgname".install
+
+prepare() {
+ [[ -d build ]] && rm -r build
+ mkdir build
+}
+
+build() {
+ cd build
+ qmake-qt5 "$srcdir"/plantumlqeditor
+ make
+}
+
+package() {
+ cd "$srcdir"/build
+ mkdir -p "$pkgdir"/usr/bin/
+ cp release/plantumlqeditor "$pkgdir"/usr/bin/
+
+ cd "$srcdir"/plantumlqeditor
+ mkdir -p "$pkgdir"/usr/share/applications/
+ mkdir -p "$pkgdir"/usr/share/icons/hicolor/32x32/apps
+ mkdir -p "$pkgdir"/usr/share/icons/hicolor/48x48/apps
+ mkdir -p "$pkgdir"/usr/share/icons/hicolor/64x64/apps
+ cp plantumlqeditor.desktop "$pkgdir"/usr/share/applications/plantumlqeditor.desktop
+ cp resources/icon32.png "$pkgdir"/usr/share/icons/hicolor/32x32/apps/plantumlqeditor.png
+ cp resources/icon48.png "$pkgdir"/usr/share/icons/hicolor/48x48/apps/plantumlqeditor.png
+ cp resources/icon64.png "$pkgdir"/usr/share/icons/hicolor/64x64/apps/plantumlqeditor.png
+}
diff --git a/plantumlqeditor-git.install b/plantumlqeditor-git.install
new file mode 100644
index 000000000000..7ca73c87e61b
--- /dev/null
+++ b/plantumlqeditor-git.install
@@ -0,0 +1,36 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+#post_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}
+