summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaurent Brock2024-03-20 19:03:33 +0100
committerLaurent Brock2024-03-20 19:03:33 +0100
commit76ebd0489c6a1678c8deeb42417de0cf57c9ea0c (patch)
tree625d1b8e6710d1d9cf99a57ce2a1916c8fdc3c8d
downloadaur-76ebd0489c6a1678c8deeb42417de0cf57c9ea0c.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD54
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..932b31523c51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = plasma-active-accent-decorations
+ pkgdesc = Window styles for KDE Plasma highlighting the active window in the color scheme's accent color
+ pkgver = 9.2
+ pkgrel = 1
+ url = https://github.com/nclarius/Plasma-window-decorations
+ arch = any
+ license = GPL3
+ conflicts = plasma-active-accent-frame-decorations
+ source = plasma-active-accent-decorations-9.2.tar.gz::https://github.com/nclarius/Plasma-window-decorations/archive/refs/tags/v9.2.tar.gz
+ sha256sums = e85f95832c988154a065daba6289fe5197f32aee5eaeec1726cb251fdea2f61f
+ sha512sums = eb426f896171d53ffa70470139b6ae132ab6932d8646887e62315dcbe6ba22ed66d2feec11d78bb84ba75cd0178ab542285960349615f8bc4faca27f24ac8b0a
+
+pkgname = plasma-active-accent-decorations
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e80c023be1f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+PACKAGER="Laurent Brock <incognito0135@protonmail.com>"
+
+pkgname=plasma-active-accent-decorations
+pkgver=9.2
+pkgrel=1
+pkgdesc="Window styles for KDE Plasma highlighting the active window in the color scheme's accent color"
+url='https://github.com/nclarius/Plasma-window-decorations'
+license=('GPL3')
+arch=('any')
+source=("$pkgname-$pkgver.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('e85f95832c988154a065daba6289fe5197f32aee5eaeec1726cb251fdea2f61f')
+sha512sums=('eb426f896171d53ffa70470139b6ae132ab6932d8646887e62315dcbe6ba22ed66d2feec11d78bb84ba75cd0178ab542285960349615f8bc4faca27f24ac8b0a')
+conflicts=('plasma-active-accent-frame-decorations')
+
+# prepare() {
+# cd "${srcdir}"
+# tar -xf "Plasma-window-decorations-${pkgver}.tar.gz"
+# }
+
+package() {
+ cd ${srcdir}/Plasma-window-decorations-${pkgver}/ActiveAccentFrame
+ install -Dm755 --directory ActiveAccentFrame "$pkgdir/usr/share/aurorae/themes/ActiveAccentFrame"
+ install -Dm644 ActiveAccentFramerc "$pkgdir"/usr/share/aurorae/themes/ActiveAccentFrame/ActiveAccentFramerc
+ install -Dm644 decoration.svg "$pkgdir"/usr/share/aurorae/themes/ActiveAccentFrame/decoration.svg
+ install -Dm644 metadata.desktop "$pkgdir"/usr/share/aurorae/themes/ActiveAccentFrame/metadata.desktop
+
+ cd ${srcdir}/Plasma-window-decorations-${pkgver}/ActiveAccentDawn
+ install -Dm755 --directory ActiveAccentDawn "$pkgdir/usr/share/aurorae/themes/ActiveAccentDawn"
+ install -Dm644 ActiveAccentDawnrc "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDawn/ActiveAccentDawnrc
+ install -Dm644 decoration.svg "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDawn/decoration.svg
+ install -Dm644 metadata.desktop "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDawn/metadata.desktop
+
+ cd ${srcdir}/Plasma-window-decorations-${pkgver}/ActiveAccentDusk
+ install -Dm755 --directory ActiveAccentDusk "$pkgdir/usr/share/aurorae/themes/ActiveAccentDusk"
+ install -Dm644 ActiveAccentDuskrc "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDusk/ActiveAccentDuskrc
+ install -Dm644 decoration.svg "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDusk/decoration.svg
+ install -Dm644 metadata.desktop "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDusk/metadata.desktop
+
+ cd ${srcdir}/Plasma-window-decorations-${pkgver}/ActiveAccentDark
+ install -Dm755 --directory ActiveAccentDark "$pkgdir/usr/share/aurorae/themes/ActiveAccentDark"
+ install -Dm644 ActiveAccentDarkrc "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDark/ActiveAccentDarkrc
+ install -Dm644 decoration.svg "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDark/decoration.svg
+ install -Dm644 metadata.desktop "$pkgdir"/usr/share/aurorae/themes/ActiveAccentDark/metadata.desktop
+
+ cd ${srcdir}/Plasma-window-decorations-${pkgver}/ActiveAccentLight
+ install -Dm755 --directory ActiveAccentLight "$pkgdir/usr/share/aurorae/themes/ActiveAccentLight"
+ install -Dm644 ActiveAccentLightrc "$pkgdir"/usr/share/aurorae/themes/ActiveAccentLight/ActiveAccentLightrc
+ install -Dm644 decoration.svg "$pkgdir"/usr/share/aurorae/themes/ActiveAccentLight/decoration.svg
+ install -Dm644 metadata.desktop "$pkgdir"/usr/share/aurorae/themes/ActiveAccentLight/metadata.desktop
+
+
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}
+