summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2017-02-05 02:07:40 +0100
committerMatMoul2017-02-05 02:07:40 +0100
commitd5af9d91bcd857db78ff5dec419023e72c6f1ade (patch)
treeb1184d2f752a89ee1e2877f0c6461fc7fb3e8d65
downloadaur-d5af9d91bcd857db78ff5dec419023e72c6f1ade.tar.gz
New version
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
-rw-r--r--plasma-addons-customdesktopmenu-git.install31
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0245d0f30e5a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sun Feb 5 01:07:40 UTC 2017
+pkgbase = plasma-addons-customdesktopmenu-git
+ pkgdesc = Custom desktop menu for Plasma5
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/MatMoul/plasma-containmentactions-customdesktopmenu
+ install = plasma-addons-customdesktopmenu-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = make
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ options = !emptydirs
+ source = git://github.com/MatMoul/plasma-containmentactions-customdesktopmenu.git
+ md5sums = SKIP
+
+pkgname = plasma-addons-customdesktopmenu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb36b4d09642
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: MatMoul <matmoul@gmail.com>
+
+pkgname=plasma-addons-customdesktopmenu-git
+_appname=plasma-addons-customdesktopmenu
+_gitname=plasma-containmentactions-customdesktopmenu
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Custom desktop menu for Plasma5"
+arch=('i686' 'x86_64')
+url="https://github.com/MatMoul/plasma-containmentactions-customdesktopmenu"
+license=('GPL2')
+makedepends=('git' 'make' 'cmake' 'extra-cmake-modules')
+install=${pkgname}.install
+options=(!emptydirs)
+source=("git://github.com/MatMoul/${_gitname}.git")
+md5sums=('SKIP')
+
+build() {
+ cd ${_gitname}/src
+ mkdir build
+ cd build
+ installlibdir=$(dirname $(dirname $(find /usr -name plasma_containmentactions_applauncher.so)))
+ cmake -DKDE_INSTALL_LIBDIR=$installlibdir ..
+ make
+}
+
+package() {
+ cd ${_gitname}/src/build
+ installlibdir=$(dirname $(dirname $(find /usr -name plasma_containmentactions_applauncher.so)))
+ mkdir -p ${pkgdir}${installlibdir}
+ cp plasma_containmentactions_customdesktopmenu.so ${pkgdir}${installlibdir}
+ chmod -R 755 ${pkgdir}${installlibdir}
+}
diff --git a/plasma-addons-customdesktopmenu-git.install b/plasma-addons-customdesktopmenu-git.install
new file mode 100644
index 000000000000..fdddffd9b607
--- /dev/null
+++ b/plasma-addons-customdesktopmenu-git.install
@@ -0,0 +1,31 @@
+## arg 1: the new package version
+pre_install() {
+ echo ""
+}
+
+## arg 1: the new package version
+post_install() {
+ kbuildsycoca5
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+pre_upgrade() {
+ echo ""
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ kbuildsycoca5
+}
+
+## arg 1: the old package version
+pre_remove() {
+ echo ""
+}
+
+## arg 1: the old package version
+post_remove() {
+ kbuildsycoca5
+}