summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2024-03-06 23:19:05 +0100
committerMatMoul2024-03-06 23:19:05 +0100
commitde13b25aa78eee31c5159a187f912a030020394f (patch)
treea28c68274a00c9356ba1b32581150ec0f732fcec
parentbb2e152db4fa47e2322ae8cf9715238763dab4af (diff)
downloadaur-de13b25aa78eee31c5159a187f912a030020394f.tar.gz
Version 0.2.0.r2.afb927d-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 191d203a7c49..a8424da1e956 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = plasma-addons-customdesktopmenu-git
- pkgdesc = Custom desktop menu for Plasma5
- pkgver = 0.1.1.r1.44c78be
+ pkgdesc = Custom desktop menu for Plasma6
+ pkgver = 0.2.0.r2.afb927d
pkgrel = 1
url = https://github.com/matmoul/plasma-containmentactions-customdesktopmenu
- install = plasma-addons-customdesktopmenu-git.install
arch = any
- license = GPL2
+ license = GPL3
makedepends = git
makedepends = extra-cmake-modules
- depends = plasma-workspace
- source = git+https://github.com/matmoul/plasma-containmentactions-customdesktopmenu.git#commit=44c78befa925481ae96caa6cfd5476d13592b1d4
+ depends = kdeplasma-addons
+ source = git+https://github.com/matmoul/plasma-containmentactions-customdesktopmenu.git#commit=afb927d5febd579d4b694c75a666f443fdbc5c19
sha256sums = SKIP
pkgname = plasma-addons-customdesktopmenu-git
diff --git a/PKGBUILD b/PKGBUILD
index dbbf9f6a9e06..8b871618caf2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,27 @@
_githubuser=matmoul
_githubrepo=plasma-containmentactions-customdesktopmenu
-_gitcommit=44c78befa925481ae96caa6cfd5476d13592b1d4
+_gitcommit=afb927d5febd579d4b694c75a666f443fdbc5c19
pkgname=plasma-addons-customdesktopmenu-git
-pkgver=0.1.1.r1.44c78be
+pkgver=0.2.0.r2.afb927d
pkgrel=1
-pkgdesc='Custom desktop menu for Plasma5'
+pkgdesc='Custom desktop menu for Plasma6'
arch=('any')
url="https://github.com/${_githubuser}/${_githubrepo}"
-license=('GPL2')
-depends=('plasma-workspace')
+license=('GPL3')
+#depends=('plasma-desktop' 'kdeplasma-addons')
+depends=('kdeplasma-addons')
makedepends=('git' 'extra-cmake-modules')
-install="${pkgname}.install"
source=("git+https://github.com/${_githubuser}/${_githubrepo}.git#commit=${_gitcommit}")
sha256sums=('SKIP')
build() {
cd "${_githubrepo}"/src
- mkdir build
- cd build
- cmake ..
- make
+ ./build.sh
}
package() {
- cd "${_githubrepo}"/src/build
- install -D -m755 bin/plasma_containmentactions_customdesktopmenu.so ${pkgdir}/usr/lib/qt/plugins/plasma/containmentactions/plasma_containmentactions_customdesktopmenu.so
+ cd "${_githubrepo}"/_build
+ install -D -m755 bin/plasma/containmentactions/customdesktopmenu.so ${pkgdir}/usr/lib/qt6/plugins/plasma/containmentactions/matmoul-customdesktopmenu.so
}