summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgustawho2021-04-29 13:34:26 -0600
committergustawho2021-04-29 13:34:26 -0600
commit9fad586627fe1e3e473d0505e871601dc71050f0 (patch)
tree08c62506944eba332563b82058f414bfef34c982
parenta612d67b1ae9bbc20dccf57a32871a9576d27df5 (diff)
downloadaur-9fad586627fe1e3e473d0505e871601dc71050f0.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1519dfecf7f4..aa9c8fa80db7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,28 @@
pkgbase = plasma-angelfish
pkgdesc = Web browser for Plasma Mobile
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
url = https://invent.kde.org/plasma-mobile/angelfish
arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
license = GPL2
makedepends = extra-cmake-modules
makedepends = corrosion-git
+ makedepends = qt5-svg
+ makedepends = qt5-tools
depends = qt5-webengine
depends = purpose
depends = kirigami2
+ depends = ki18n
+ depends = kconfig
+ depends = kcoreaddons
+ depends = kdbusaddons
+ depends = kwindowsystem
+ depends = knotifications
source = https://download.kde.org/stable/angelfish/1.8.0/angelfish-1.8.0.tar.xz
sha256sums = def9a40de962c634304eadb91d505aa21faa70d327270e9de85b34c471ca8cd8
diff --git a/PKGBUILD b/PKGBUILD
index 7a36a6b1fd49..169166a8f73c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,22 @@
pkgname=plasma-angelfish
pkgver=1.8.0
-pkgrel=1
-arch=('x86_64')
+pkgrel=2
+arch=(x86_64 i686 arm armv6h armv7h aarch64)
pkgdesc="Web browser for Plasma Mobile"
url="https://invent.kde.org/plasma-mobile/angelfish"
license=('GPL2')
-depends=('qt5-webengine' 'purpose' 'kirigami2')
-makedepends=('extra-cmake-modules' 'corrosion-git')
+depends=('qt5-webengine' 'purpose' 'kirigami2' 'ki18n' 'kconfig'
+ 'kcoreaddons' 'kdbusaddons' 'kwindowsystem' 'knotifications')
+makedepends=('extra-cmake-modules' 'corrosion-git' 'qt5-svg' 'qt5-tools')
source=("https://download.kde.org/stable/angelfish/${pkgver}/angelfish-${pkgver}.tar.xz")
sha256sums=('def9a40de962c634304eadb91d505aa21faa70d327270e9de85b34c471ca8cd8')
build() {
- cd ${srcdir}/angelfish-${pkgver}
- cmake -DCMAKE_INSTALL_PREFIX=/usr -B build
- make -C build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -B build -S angelfish-${pkgver}
+ cmake --build build --config Release
}
package() {
- cd ${srcdir}/angelfish-${pkgver}
- make -C build DESTDIR="${pkgdir}" PREFIX=/usr install
-}
-
-#vim: syntax=sh
+ DESTDIR="${pkgdir}" cmake --install build --config Release
+} \ No newline at end of file