summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStoyan Minaev2019-11-30 13:39:14 +0200
committerStoyan Minaev2019-11-30 13:39:14 +0200
commitdeb960295d35445c614b81f495b7426bfed94845 (patch)
treedc91b36833fcdafe752031eff28033c226212e8d
downloadaur-deb960295d35445c614b81f495b7426bfed94845.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD44
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd06a4b2e868
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plasma-angelfish
+ pkgdesc = Plasma Demo Webbrowser for Mobile Devices
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/KDE/plasma-angelfish
+ arch = x86_64
+ license = GPL2
+ makedepends = extra-cmake-modules
+ depends = plasma-framework
+ source = https://codeload.github.com/KDE/plasma-angelfish/tar.gz/v1.3.0
+ md5sums = 777e55a620b1c53cf584c636fd89e93b
+
+pkgname = plasma-angelfish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c1f277f6847
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer KDE
+# Maintainer Stoyan Minaev <stoyan.minaev@gmail.com>
+
+pkgbase=plasma-angelfish
+pkgname=plasma-angelfish
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="Plasma Demo Webbrowser for Mobile Devices"
+url="https://github.com/KDE/plasma-angelfish"
+license=('GPL2')
+source=(
+ https://codeload.github.com/KDE/$pkgname/tar.gz/v$pkgver
+)
+md5sums=(
+ '777e55a620b1c53cf584c636fd89e93b'
+)
+arch=('x86_64')
+
+depends=(
+ plasma-framework
+)
+
+makedepends=(
+ extra-cmake-modules
+)
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ mkdir -p build
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="/usr/local" -DBUILD_TESTING=OFF ..
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ cd build
+ make DESTDIR="$pkgdir" install
+}
+
+#vim: syntax=sh