summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryaute2018-12-13 23:26:14 +0100
committeryaute2018-12-13 23:26:14 +0100
commit29509f86804bd7fcbaef6c713e5ce2144e3fbcc8 (patch)
tree39252a01ad4603f0ff7697f80eb5b693020e9ac7
downloadaur-29509f86804bd7fcbaef6c713e5ce2144e3fbcc8.tar.gz
create
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8dea7f2484e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plasma-applet-custom-notifier
+ pkgdesc = Plasmoid to be notified of updates with custom scripts.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/yaute74/custom-notifier.git
+ arch = any
+ license = GPL
+ depends = plasma-workspace
+ depends = qt5-graphicaleffects
+ source = https://gitlab.com/yaute74/custom-notifier/uploads/ccddc6a588b81e9f8277934b09f8675e/custom-notifier-1.0.plasmoid
+ md5sums = c39b91b3a790deb9f5fb1b172abdb6a7
+
+pkgname = plasma-applet-custom-notifier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0ce3b4d7416
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Submitter: yaute <yaute74@gmail.com>
+
+pkgname=plasma-applet-custom-notifier
+pkgver=1.0
+pkgrel=1
+pkgdesc="Plasmoid to be notified of updates with custom scripts."
+arch=('any')
+url="https://gitlab.com/yaute74/custom-notifier.git"
+license=('GPL')
+depends=('plasma-workspace' 'qt5-graphicaleffects')
+source=("https://gitlab.com/yaute74/custom-notifier/uploads/ccddc6a588b81e9f8277934b09f8675e/custom-notifier-$pkgver.plasmoid")
+md5sums=('c39b91b3a790deb9f5fb1b172abdb6a7')
+
+package() {
+ rm custom-notifier-$pkgver.plasmoid
+
+ mkdir -p $pkgdir/usr/share/plasma/plasmoids/org.kde.plasma.custom-notifier
+ cp -r * $pkgdir/usr/share/plasma/plasmoids/org.kde.plasma.custom-notifier
+}