summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-01 23:37:04 +0000
committerJoão Figueiredo2021-02-01 23:37:04 +0000
commit32cddfa0b94d72b5cdf808bc2988f24a3c4eb14e (patch)
tree9efd5ec68ef6ba03354eba824ef37de711f51cca
parent35f9626af9658aa6726b7a3a42485f857df68dad (diff)
downloadaur-32cddfa0b94d72b5cdf808bc2988f24a3c4eb14e.tar.gz
Merged with official ABS plasma-desktop PKGBUILD
-rw-r--r--.SRCINFO53
-rw-r--r--PKGBUILD70
2 files changed, 51 insertions, 72 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9eb72d8d9d42..835f1d892879 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = plasma-desktop-git
pkgdesc = KDE Plasma Desktop
- pkgver = r7992.105369274
+ pkgver = 5.21.80_r8192.g6be4dd2d6
pkgrel = 1
- url = https://projects.kde.org/projects/kde/kde-workspace
- arch = i686
+ url = https://kde.org/plasma-desktop/
arch = x86_64
- groups = plasma
+ groups = plasma-git
license = LGPL
+ makedepends = git
makedepends = extra-cmake-modules-git
makedepends = kdoctools-git
makedepends = xf86-input-evdev
@@ -14,42 +14,37 @@ pkgbase = plasma-desktop-git
makedepends = xf86-input-libinput
makedepends = xorg-server-devel
makedepends = scim
- makedepends = kdesignerplugin
- makedepends = kaccounts-integration
+ makedepends = kdesignerplugin-git
+ makedepends = kaccounts-integration-git
makedepends = intltool
- makedepends = git
- depends = polkit-kde-agent-git
- depends = libxkbfile
- depends = kmenuedit-git
- depends = systemsettings-git
- depends = ksysguard-git
- depends = baloo-git
- depends = accountsservice
- source = git+https://github.com/KDE/plasma-desktop.git
- md5sums = SKIP
-
-pkgname = plasma-desktop-git
depends = polkit-kde-agent-git
depends = libxkbfile
depends = kmenuedit-git
depends = systemsettings-git
depends = ksysguard-git
depends = baloo-git
+ depends = libibus
depends = accountsservice
- depends = knetattach
- optdepends = plasma-nm: Network manager applet
- optdepends = powerdevil: power management, suspend and hibernate support
- optdepends = kscreen: screen management
+ optdepends = plasma-nm-git: Network manager applet
+ optdepends = powerdevil-git: power management, suspend and hibernate support
+ optdepends = kscreen-git: screen management
optdepends = ibus: kimpanel IBUS support
optdepends = scim: kimpanel SCIM support
- optdepends = kaccounts-integration: OpenDesktop integration plugin
+ optdepends = kaccounts-integration-git: OpenDesktop integration plugin
provides = plasma-desktop
- conflicts = plasma-desktop
- replaces = user-manager
-
-pkgname = knetattach-git
- pkgdesc = Wizard which makes it easier to integrate network resources with the Plasma Desktop
- depends = kdelibs4support-git
+ provides = user-manager
provides = knetattach
+ provides = user-manager-git
+ provides = knetattach-git
+ conflicts = plasma-desktop
+ conflicts = user-manager
conflicts = knetattach
+ conflicts = user-manager-git
+ conflicts = knetattach-git
+ replaces = user-manager-git
+ replaces = knetattach-git
+ source = git+https://github.com/KDE/plasma-desktop.git
+ sha256sums = SKIP
+
+pkgname = plasma-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index 9633e2a8b67e..22f51476fa7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,58 +1,42 @@
-# Maintainer: João Figueiredo <jf dot mundox at gmail dot com>
+# Merged with official ABS plasma-desktop PKGBUILD by João, 2021/01/31 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
# Contributor: Antonio Rojas <arojas@archlinux.org>
-pkgbase=plasma-desktop-git
-pkgname=(plasma-desktop-git knetattach-git)
-pkgver=r7992.105369274
+pkgname=plasma-desktop-git
+pkgver=5.21.80_r8192.g6be4dd2d6
pkgrel=1
pkgdesc='KDE Plasma Desktop'
-arch=(i686 x86_64)
-url='https://projects.kde.org/projects/kde/kde-workspace'
+arch=($CARCH)
+url='https://kde.org/plasma-desktop/'
license=(LGPL)
-depends=(polkit-kde-agent-git libxkbfile kmenuedit-git systemsettings-git ksysguard-git baloo-git accountsservice)
-makedepends=(extra-cmake-modules-git kdoctools-git xf86-input-evdev xf86-input-synaptics xf86-input-libinput xorg-server-devel scim kdesignerplugin kaccounts-integration intltool git)
-source=("git+https://github.com/KDE/plasma-desktop.git")
-groups=(plasma)
-md5sums=('SKIP')
+groups=(plasma-git)
+depends=(polkit-kde-agent-git libxkbfile kmenuedit-git systemsettings-git ksysguard-git baloo-git libibus accountsservice)
+optdepends=('plasma-nm-git: Network manager applet'
+ 'powerdevil-git: power management, suspend and hibernate support'
+ 'kscreen-git: screen management'
+ 'ibus: kimpanel IBUS support'
+ 'scim: kimpanel SCIM support'
+ 'kaccounts-integration-git: OpenDesktop integration plugin')
+conflicts=(${pkgname%-git} user-manager knetattach user-manager-git knetattach-git)
+provides=(${pkgname%-git} user-manager knetattach user-manager-git knetattach-git)
+replaces=(user-manager-git knetattach-git)
+makedepends=(git extra-cmake-modules-git kdoctools-git xf86-input-evdev xf86-input-synaptics xf86-input-libinput xorg-server-devel scim kdesignerplugin-git kaccounts-integration-git intltool)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
- cd plasma-desktop
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 'set(PROJECT_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- cmake -B build -S plasma-desktop \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DKDE_INSTALL_LIBDIR=lib \
- -DKDE_INSTALL_LIBEXECDIR=lib \
- -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ cmake -B build -S ${pkgname%-git} \
+ -DCMAKE_INSTALL_LIBEXECDIR=lib \
+ -DBUILD_TESTING=OFF
cmake --build build
}
-package_plasma-desktop-git() {
- conflicts=(plasma-desktop)
- provides=(plasma-desktop)
- depends+=(knetattach)
- optdepends=('plasma-nm: Network manager applet'
- 'powerdevil: power management, suspend and hibernate support'
- 'kscreen: screen management'
- 'ibus: kimpanel IBUS support'
- 'scim: kimpanel SCIM support'
- 'kaccounts-integration: OpenDesktop integration plugin')
- replaces=(user-manager)
-
+package() {
DESTDIR="$pkgdir" cmake --install build
-
-# Split knetattach
- rm "$pkgdir"/usr/{bin/knetattach,share/applications/org.kde.knetattach.desktop}
-}
-
-package_knetattach-git() {
- pkgdesc='Wizard which makes it easier to integrate network resources with the Plasma Desktop'
- conflicts=(knetattach)
- provides=(knetattach)
- depends=(kdelibs4support-git)
-
- DESTDIR="$pkgdir" cmake --install build/knetattach
}