summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlejandro Valdes2018-12-15 12:26:16 -0500
committerAlejandro Valdes2018-12-15 12:26:16 -0500
commit8c6013ecb7a7fc00d40de8ff264ff9db083833fe (patch)
tree9ea27e6e98b95f66d8fe59f6fdfa5f576d2dfc15
downloadaur-8c6013ecb7a7fc00d40de8ff264ff9db083833fe.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
-rw-r--r--plasma-hud-git.install15
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7412b40b519e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = plasma-hud-git
+ pkgver = 16.10.0.r90.g7ff3752
+ pkgrel = 1
+ url = https://github.com/Zren/plasma-hud
+ install = plasma-hud-git.install
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = plasma-workspace
+ depends = rofi
+ depends = python
+ depends = python-dbus
+ depends = python-setproctitle
+ depends = python-xlib
+ depends = gobject-introspection
+ depends = appmenu-gtk-module
+ depends = appmenu-qt4
+ source = git+https://github.com/Zren/plasma-hud.git
+ sha256sums = SKIP
+
+pkgname = plasma-hud-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ee53a6b9248
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=plasma-hud-git
+pkgver=16.10.0.r90.g7ff3752
+pkgrel=1
+pkgdesk="Provides a way to run menubar commands through rofi, much like the Unity 7 Heads-Up Display (HUD)."
+arch=(x86_64)
+url="https://github.com/Zren/plasma-hud"
+license=(GPL)
+depends=(plasma-workspace rofi python python-dbus python-setproctitle python-xlib gobject-introspection appmenu-gtk-module appmenu-qt4)
+makedepends=(git)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+install=${pkgname}.install
+
+pkgver() {
+ cd plasma-hud
+ git describe --long | sed 's/^[v-]//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _pkgdir="$pkgdir/usr/lib/plasma-hud"
+ mkdir -p $_pkgdir
+ cp -r plasma-hud/usr/lib/plasma-hud/* "$_pkgdir"
+ mkdir -p "$pkgdir/etc/xdg/autostart"
+ cp plasma-hud/etc/xdg/autostart/* "$pkgdir/etc/xdg/autostart"
+}
diff --git a/plasma-hud-git.install b/plasma-hud-git.install
new file mode 100644
index 000000000000..15f05adbba69
--- /dev/null
+++ b/plasma-hud-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ # Note to enable the HUD menu by using alt
+ cat << _EOF
+
+ ==> Run the following commands to bind the Alt keys to plasma-hud:
+ ------------------------------------------------------------------------------
+ kwriteconfig5 --file ~/.config/kwinrc --group ModifierOnlyShortcuts --key Alt "com.github.zren.PlasmaHUD,/PlasmaHUD,com.github.zren.PlasmaHUD,toggleHUD"
+ qdbus org.kde.KWin /KWin reconfigure
+
+_EOF
+}
+
+post_upgrade() {
+ post_install
+}