summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2021-02-02 18:16:06 +0000
committerJoão Figueiredo2021-02-02 18:16:06 +0000
commitaf251828a4cf63ef12f0ea7077ce999c6a9ef595 (patch)
tree09733ad857e8e4aa2f86a734abd81d03db88bc57
downloadaur-af251828a4cf63ef12f0ea7077ce999c6a9ef595.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD33
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7dd7176f5c25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = plasma-integration-git
+ pkgdesc = Qt Platform Theme integration plugins for the Plasma workspaces
+ pkgver = 5.21.80_r505.gb6f4feb
+ pkgrel = 1
+ url = https://kde.org/plasma-desktop/
+ arch = x86_64
+ groups = plasma-git
+ license = LGPL
+ makedepends = git
+ makedepends = extra-cmake-modules-git
+ makedepends = breeze-git
+ depends = kio-git
+ depends = kwayland-git
+ depends = libxcursor
+ depends = noto-fonts
+ depends = ttf-hack
+ depends = qqc2-desktop-style-git
+ depends = perl
+ provides = plasma-integration
+ conflicts = plasma-integration
+ source = git+https://github.com/KDE/plasma-integration.git
+ sha256sums = SKIP
+
+pkgname = plasma-integration-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0b773fcf1d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Merged with official ABS plasma-integration PKGBUILD by João, 2021/02/02 (all respective contributors apply herein)
+# Maintainer: João Figueiredo <jf.mundox@gmail.com>
+
+pkgname=plasma-integration-git
+pkgver=5.21.80_r505.gb6f4feb
+pkgrel=1
+pkgdesc="Qt Platform Theme integration plugins for the Plasma workspaces"
+arch=($CARCH)
+url='https://kde.org/plasma-desktop/'
+license=(LGPL)
+depends=(kio-git kwayland-git libxcursor noto-fonts ttf-hack qqc2-desktop-style-git perl)
+makedepends=(git extra-cmake-modules-git breeze-git)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(plasma-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ _ver="$(grep -m1 'set(PROJECT_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}