summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorw2016-03-31 16:23:10 +0500
committerw2016-03-31 16:23:10 +0500
commitaff0fae49bc1658d6a39bebb6e042e0ef3cdfa3d (patch)
tree19c9561e0d7918c436d970234d33edbd8372d8d0
downloadaur-plasma-midna-theme-git.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD42
-rw-r--r--plasma-midna-theme-git.install12
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..876e9a1e8e49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Mar 31 11:03:50 UTC 2016
+pkgbase = plasma-midna-theme-git
+ pkgdesc = KaOS grey KDM-Theme.
+ pkgver = r152.8359aaa
+ pkgrel = 1
+ url = http://kaosx.us
+ install = plasma-midna-theme-git.install
+ arch = i686
+ arch = x86_64
+ groups = plasma
+ license = GPL
+ source = git://github.com/KaOSx/midna.git
+ md5sums = SKIP
+
+pkgname = plasma-midna-theme-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e38977a6173
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Warlock9000
+
+pkgname=plasma-midna-theme-git
+pkgver=r152.8359aaa
+pkgrel=1
+pkgdesc="KaOS grey KDM-Theme."
+arch=('i686' 'x86_64')
+url="http://kaosx.us"
+license=('GPL')
+groups=(plasma)
+source=("git://github.com/KaOSx/midna.git")
+md5sums=('SKIP')
+install=$pkgname.install
+
+pkgver() {
+ cd midna
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../midna \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=lib \
+ -DKDE_INSTALL_USE_QT_SYS_PATHS=ON
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+
+# make QtCurve preset and color scheme available for KDE4 too
+ install -d -m755 "$pkgdir"/usr/share/apps/{QtCurve,color-schemes}
+ ln -sr "$pkgdir"/usr/share/QtCurve/Midna.qtcurve "$pkgdir"/usr/share/apps/QtCurve
+ ln -sr "$pkgdir"/usr/share/color-schemes/Midna*.colors "$pkgdir"/usr/share/apps/color-schemes
+}
diff --git a/plasma-midna-theme-git.install b/plasma-midna-theme-git.install
new file mode 100644
index 000000000000..f80ffb217b01
--- /dev/null
+++ b/plasma-midna-theme-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}