summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-02-18 20:31:40 +0000
committerAntonio Rojas2019-02-18 20:31:40 +0000
commit17aae5185a426384e57eaa90f057abeca0827854 (patch)
treeabf968da256cae94c68be629359747b3aa9d6032
downloadaur-17aae5185a426384e57eaa90f057abeca0827854.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d486d98a88fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = plasma-pass
+ pkgdesc = Plasma applet for the Pass password manager
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://www.dvratil.cz/2018/05/plasma-pass/
+ arch = x86_64
+ license = GPL
+ makedepends = extra-cmake-modules
+ depends = plasma-workspace
+ source = https://download.kde.org/stable/plasma-pass/plasma-pass-1.0.0.tar.xz
+ source = https://download.kde.org/stable/plasma-pass/plasma-pass-1.0.0.tar.xz.sig
+ validpgpkeys = 0ABDFA55A4E6BEA99A83EA974D69557AECB13683
+ sha256sums = 9821c5ad80e4370dce002855bd0300d234feec249258b01fafd9e3a9241cbc66
+ sha256sums = SKIP
+
+pkgname = plasma-pass
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17421f5aaf0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+
+pkgname=plasma-pass
+pkgver=1.0.0
+pkgrel=1
+arch=(x86_64)
+pkgdesc="Plasma applet for the Pass password manager"
+url="https://www.dvratil.cz/2018/05/plasma-pass/"
+license=(GPL)
+depends=(plasma-workspace)
+makedepends=(extra-cmake-modules)
+source=(https://download.kde.org/stable/$pkgname/$pkgname-$pkgver.tar.xz{,.sig})
+sha256sums=('9821c5ad80e4370dce002855bd0300d234feec249258b01fafd9e3a9241cbc66'
+ 'SKIP')
+validpgpkeys=('0ABDFA55A4E6BEA99A83EA974D69557AECB13683') # Daniel Vrátil <dvratil@kde.org>
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package(){
+ cd build
+ make DESTDIR="$pkgdir" install
+}