summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiachen YANG2020-10-22 11:48:34 +0900
committerJiachen YANG2020-10-22 11:48:34 +0900
commit1871e30e7bdaf119314522bb504489adf196dd20 (patch)
tree18626b1e06b33a30775892b51657696a669b7cb2
downloadaur-1871e30e7bdaf119314522bb504489adf196dd20.tar.gz
new package plasma-systemmonitor-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d24179b0e0ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = plasma-systemmonitor-git
+ pkgdesc = an interface for monitoring system sensors, process information and other system resources
+ pkgver = r248.32afb36
+ pkgrel = 1
+ url = https://github.com/KDE/plasma-systemmonitor
+ arch = x86_64
+ license = GPL3
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = qt5-tools
+ depends = ksysguard
+ depends = libksysguard
+ depends = qt5-quickcontrols
+ depends = kirigami2
+ provides = plasma-systemmonitor
+ source = plasma-systemmonitor::git+https://github.com/KDE/plasma-systemmonitor.git
+ sha256sums = SKIP
+
+pkgname = plasma-systemmonitor-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9291ec285ae9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Jiachen YANG <farseerfc@gmail.com>
+
+_pkgname='plasma-systemmonitor'
+pkgname="${_pkgname,,}-git"
+pkgver=r248.32afb36
+pkgrel=1
+pkgdesc='an interface for monitoring system sensors, process information and other system resources'
+arch=('x86_64')
+url='https://github.com/KDE/plasma-systemmonitor'
+license=('GPL3')
+depends=('ksysguard' 'libksysguard' 'qt5-quickcontrols' 'kirigami2')
+makedepends=('extra-cmake-modules' 'git' 'qt5-tools')
+provides=("${_pkgname,,}")
+source=("${_pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cmake -B build -S "${_pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C build
+}
+
+package() {
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
+}
+
+# vim: ts=2 sw=2 et: