summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorguidobelix2015-06-10 20:46:38 +0200
committerguidobelix2015-06-10 20:46:38 +0200
commitbce0fa5b25f622113eb8d7f7079c69697a1ea048 (patch)
tree8ee5bfd76060ed910e58f06050cfab0136bf9d3c
downloadaur-bce0fa5b25f622113eb8d7f7079c69697a1ea048.tar.gz
First commit to AUR4
new file: .SRCINFO new file: PKGBUILD new file: plasma-theme-archlinux.install
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rw-r--r--plasma-theme-archlinux.install5
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..076454bc2d6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plasma-theme-archlinux
+ pkgdesc = Plasma 5 theme inspited by Archlinux minimalism
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://www.archlinux.org/
+ install = plasma-theme-archlinux.install
+ arch = any
+ license = CCPL:cc-by-sa
+ depends = plasma-workspace
+ source = https://github.com/Guidobelix/plasma-theme-archlinux/releases/download/v1.0/plasma-theme-archlinux-1.0.tar.bz2
+ md5sums = bf2eb7796c90a09960d9b2c77c33c5d8
+
+pkgname = plasma-theme-archlinux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9999ab234033
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Guidobelix <guidobelix at hotmail dot it>
+
+pkgname=plasma-theme-archlinux
+pkgver=1.0
+pkgrel=2
+pkgdesc="Plasma 5 theme inspited by Archlinux minimalism"
+arch=('any')
+url="http://www.archlinux.org/"
+license=('CCPL:cc-by-sa')
+depends=('plasma-workspace')
+install="$pkgname.install"
+source="https://github.com/Guidobelix/plasma-theme-archlinux/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.bz2"
+md5sums='bf2eb7796c90a09960d9b2c77c33c5d8'
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/plasma/look-and-feel
+ cp -r "$pkgname-$pkgver"/look-and-feel/org.archlinux.archlinux "${pkgdir}"/usr/share/plasma/look-and-feel/org.archlinux.archlinux
+ mkdir -p "${pkgdir}"/usr/share/wallpapers
+ cp -r "$pkgname-$pkgver"/wallpapers/Archlinux "${pkgdir}"/usr/share/wallpapers/Archlinux
+ mkdir -p "${pkgdir}"/usr/share/plasma/desktoptheme
+ cp -r "$pkgname-$pkgver"/desktoptheme/archlinux "${pkgdir}"/usr/share/plasma/desktoptheme/archlinux
+ mkdir -p "${pkgdir}"/usr/share/color-schemes
+ for t in Archlinux ArchlinuxDark; do
+ cp "$pkgname-$pkgver"/color-schemes/$t.colors "${pkgdir}"/usr/share/color-schemes/
+ done
+}
diff --git a/plasma-theme-archlinux.install b/plasma-theme-archlinux.install
new file mode 100644
index 000000000000..ce5d9c53cd1a
--- /dev/null
+++ b/plasma-theme-archlinux.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "To use this theme, select and apply the theme an the wallpaper:"
+ echo " System Settings > Workspace Appearance > Desktop Theme > Archlinux"
+ echo " Desktop Settings > Background > Archlinux"
+}