summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordundee812019-02-02 11:04:17 +0100
committerdundee812019-02-02 11:04:17 +0100
commit24b866de2a07b3af47aa1a0497bd68d90896d8fd (patch)
tree86c64044625e6ded385d379a9eecaf70c2dcd842
downloadaur-24b866de2a07b3af47aa1a0497bd68d90896d8fd.tar.gz
First release of 8.7.1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05dc9859ad75
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = plasma-theme-helium-git
+ pkgdesc = A translucent theme for Plasma 5
+ pkgver = 8.7.1
+ pkgrel = 1
+ url = https://github.com/mcder3/Helium-Plasma-Theme
+ arch = any
+ license = Creative Commons
+ makedepends = git
+ provides = plasma-theme-helium
+ conflicts = plasma-theme-helium
+ options = !strip
+ source = plasma-theme-helium-git::git+https://github.com/mcder3/Helium-Plasma-Theme.git
+ sha256sums = SKIP
+
+pkgname = plasma-theme-helium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72d03b59547c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: dundee81 <daniel.winiarski.dw@gmail.com>
+
+pkgname=('plasma-theme-helium-git')
+pkgver=8.7.1
+pkgrel=1
+pkgdesc="A translucent theme for Plasma 5"
+arch=('any')
+url="https://github.com/mcder3/Helium-Plasma-Theme"
+license=('Creative Commons')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+options=('!strip')
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/${pkgname%}"
+ rm -rf LICENSE.md
+ rm README.md
+}
+
+package() {
+ install -dm 755 "$pkgdir"/usr/share/plasma/desktoptheme/
+ cp -r ${srcdir}/${pkgname%}/* ${pkgdir}/usr/share/plasma/desktoptheme/Helium/
+}