summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2020-01-14 22:47:51 -0500
committerLeo P2020-01-14 22:47:51 -0500
commitf48b06939db8723556393b14a25ce2ca7aacf815 (patch)
treed862a59cbe88ed335e203d120ce3631ad952e0e3
parent005d1823a103aa5c0daa1e3312b83b38117fbc83 (diff)
downloadaur-f48b06939db8723556393b14a25ce2ca7aacf815.tar.gz
make that pape
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c538c078e54a..532233cdce2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
-pkgbase = plasma-wallpaper-asciiquarium-git
- pkgdesc = Plasma Wallpaper Asciiquarium
- pkgver = r33.4d6e48a
- pkgrel = 2
+pkgbase = plasma-wallpaper-makethatpape-git
+ pkgdesc = Plasma Wallpaper makeThatPape
+ pkgver = r34.ccd2d6b
+ pkgrel = 1
url = https://cgit.kde.org/scratch/mpyne/plasma_wallpaper_asciiquarium.git/about/
arch = any
license = GPL
makedepends = cmake
makedepends = extra-cmake-modules
makedepends = git
+ makedepends = tar
depends = plasma-workspace
- provides = plasma-wallpaper-asciiquarium-git
- source = git+https://anongit.kde.org/scratch/mpyne/plasma_wallpaper_asciiquarium.git
+ depends = python
+ depends = python-pillow
+ provides = plasma-wallpaper-makethatpape-git
+ source = git+https://gitlab.com/reightb/makethatpape
md5sums = SKIP
-pkgname = plasma-wallpaper-asciiquarium-git
+pkgname = plasma-wallpaper-makethatpape-git
diff --git a/PKGBUILD b/PKGBUILD
index c967fb34fe2a..0ff42978470f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-pkgname='plasma-wallpaper-asciiquarium-git'
-pkgver=r33.4d6e48a
-pkgrel=2
-pkgdesc='Plasma Wallpaper Asciiquarium'
+pkgname='plasma-wallpaper-makethatpape-git'
+pkgver=r34.ccd2d6b
+pkgrel=1
+pkgdesc='Plasma Wallpaper makeThatPape'
arch=('any')
url='https://cgit.kde.org/scratch/mpyne/plasma_wallpaper_asciiquarium.git/about/'
license=('GPL')
-depends=('plasma-workspace')
-makedepends=('cmake' 'extra-cmake-modules' 'git')
+depends=('plasma-workspace' 'python' 'python-pillow')
+makedepends=('cmake' 'extra-cmake-modules' 'git' 'tar')
provides=("${pkgname}")
-source=("git+https://anongit.kde.org/scratch/mpyne/plasma_wallpaper_asciiquarium.git")
+source=("git+https://gitlab.com/reightb/makethatpape")
md5sums=('SKIP')
pkgver() {
- cd "plasma_wallpaper_asciiquarium"
+ cd "makethatpape"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/plasma_wallpaper_asciiquarium"
- cmake -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cd "$srcdir/makethatpape"
+ ./package.sh
}
package() {
- cd "$srcdir/plasma_wallpaper_asciiquarium"
- make DESTDIR="$pkgdir/" install
+ mkdir -p $pkgdir/usr/share/plasma/wallpapers
+ cd $pkgdir/usr/share/plasma/wallpapers
+ tar -xvf $srcdir/makethatpape/makeThatPape*.tar.gz
+ mv kde-plugin org.kde.plasma.makethatpape
}