summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStMartin812020-11-12 22:33:50 +0100
committerStMartin812020-11-12 22:33:50 +0100
commitcd35e374ed5911405a05935168d0847b91121cee (patch)
treee6aa3f0ac3bbfcd8ae3e0057a32150fa68275f12
parent5d59e95f5936b46f5102f96ef9ca17e4f682aef6 (diff)
downloadaur-cd35e374ed5911405a05935168d0847b91121cee.tar.gz
Clean up PKGBUILD
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d348b08f5543..19d8ef2c2535 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Martin Stolpe <martin.stolpe[at]gmail{dot}com>
# Contributor Antonio Rojas <arojas [at] archlinux.org>
+_pkgname=plasma-wayland-protocols
pkgname=plasma-wayland-protocols-git
pkgver=r1019.314fb1c
pkgrel=1
@@ -10,18 +11,18 @@ url="https://kde.org/plasma-desktop"
license=(LGPL)
depends=()
makedepends=(qt5-base extra-cmake-modules git)
-source=("git+https://invent.kde.org/libraries/plasma-wayland-protocols")
+source=("git+https://invent.kde.org/libraries/${_pkgname}")
sha256sums=('SKIP')
-provides=('plasma-wayland-protocols')
-conflicts=('plasma-wayland-protocols')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
pkgver() {
- cd plasma-wayland-protocols
+ cd ${_pkgname}
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cmake -B build -S plasma-wayland-protocols
+ cmake -B build -S ${_pkgname}
cmake --build build
}