summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBhushan Shah2015-07-23 08:26:14 +0530
committerBhushan Shah2015-07-23 08:26:14 +0530
commitbcfd1531ec337a8e9c60b60358bf0b595025916a (patch)
treed9647dfaf7a1dc41585b69be8a6bad0fda2372fc
downloadaur-bcfd1531ec337a8e9c60b60358bf0b595025916a.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..29fc2f6acc8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = plasma-workspace-units-git
+ pkgdesc = systemd user-session units for KDE Frameworks 5 and Plasma 5
+ pkgver = 0.01
+ pkgrel = 1
+ url = https://github.com/eliasp/plasma-workspace-units
+ arch = any
+ license = GPL
+ depends = plasma-desktop
+ source = git://github.com/eliasp/plasma-workspace-units.git#commit=8729d6
+ md5sums = SKIP
+
+pkgname = plasma-workspace-units-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e675ecaeff38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bhushan Shah <bshah@kde.org>
+pkgname=plasma-workspace-units-git
+pkgver=0.01
+pkgrel=1
+arch=("any")
+pkgdesc="systemd user-session units for KDE Frameworks 5 and Plasma 5"
+url="https://github.com/eliasp/plasma-workspace-units"
+license=('GPL')
+depends=('plasma-desktop')
+conflicts=()
+source=("git://github.com/eliasp/plasma-workspace-units.git#commit=8729d6")
+md5sums=("SKIP")
+
+prepare() {
+ cd plasma-workspace-units
+ sed 's:\/usr\/local:\/usr:' -i systemd.desktop
+}
+
+package() {
+ cd plasma-workspace-units
+ install -Dm644 systemd.desktop ${pkgdir}/usr/share/xsessions/systemd.desktop
+ install -Dm755 startsystemd ${pkgdir}/usr/bin/startsystemd
+ install -Dm644 systemd/user/* -t ${pkgdir}/usr/lib/systemd/user/
+ install -Dm644 dbus/session.d/* -t ${pkgdir}/usr/lib/dbus-1/session.d/
+ install -Dm755 80-dbus ${pkgdir}/etc/X11/xinit/xinitrc.d/20-dbus
+}