summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeniy Alekseev2016-07-10 00:21:21 +0300
committerEvgeniy Alekseev2016-07-10 00:21:21 +0300
commit1d182b6680452bb8f3b493e7e9aa280e8eff163d (patch)
treebb27d231b74c9e533be6dbb669ae74d56bbcce54
parent1e2dadff1dc757614f37d3e142505b8e1fe17e21 (diff)
downloadaur-1d182b6680452bb8f3b493e7e9aa280e8eff163d.tar.gz
bump to 3.2.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--fix-vertical-alignment.patch26
3 files changed, 9 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae077551e77c..7108d1ecfb24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon May 9 01:10:25 UTC 2016
+# Sat Jul 9 21:21:10 UTC 2016
pkgbase = plasma5-applet-awesome-widgets
pkgdesc = Collection of minimalistic Plasmoids which look like Awesome WM widgets (ex-PyTextMonitor)
- pkgver = 3.1.2
- pkgrel = 2
+ pkgver = 3.2.0
+ pkgrel = 1
url = https://arcanis.me/projects/awesome-widgets
install = plasma5-applet-awesome-widgets.install
arch = i686
@@ -19,10 +19,8 @@ pkgbase = plasma5-applet-awesome-widgets
optdepends = mpd: for music player monitor
optdepends = nvidia-utils: for GPU monitor
backup = etc/xdg/plasma-dataengine-extsysmon.conf
- source = https://github.com/arcan1s/awesome-widgets/releases/download/V.3.1.2/awesome-widgets-3.1.2-src.tar.xz
- source = fix-vertical-alignment.patch
- md5sums = 99514bf6d1a5ca8660dd0210ee58af28
- md5sums = f007c9814a88ca1ff8f017245b8ae7b6
+ source = https://github.com/arcan1s/awesome-widgets/releases/download/V.3.2.0/awesome-widgets-3.2.0-src.tar.xz
+ md5sums = 81a85890d519bd8c5791d0d99cffc9c1
pkgname = plasma5-applet-awesome-widgets
diff --git a/PKGBUILD b/PKGBUILD
index 8d5980aa27e4..593162d5a93b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=plasma5-applet-awesome-widgets
_pkgname=awesome-widgets
-pkgver=3.1.2
-pkgrel=2
+pkgver=3.2.0
+pkgrel=1
pkgdesc="Collection of minimalistic Plasmoids which look like Awesome WM widgets (ex-PyTextMonitor)"
arch=('i686' 'x86_64')
url="https://arcanis.me/projects/awesome-widgets"
@@ -15,17 +15,14 @@ optdepends=("catalyst: for GPU monitor"
"mpd: for music player monitor"
"nvidia-utils: for GPU monitor")
makedepends=('cmake' 'extra-cmake-modules' 'python')
-source=(https://github.com/arcan1s/awesome-widgets/releases/download/V.${pkgver}/${_pkgname}-${pkgver}-src.tar.xz
- fix-vertical-alignment.patch)
+source=(https://github.com/arcan1s/awesome-widgets/releases/download/V.${pkgver}/${_pkgname}-${pkgver}-src.tar.xz)
install=${pkgname}.install
+md5sums=('81a85890d519bd8c5791d0d99cffc9c1')
backup=('etc/xdg/plasma-dataengine-extsysmon.conf')
prepare() {
rm -rf "${srcdir}/build"
mkdir "${srcdir}/build"
-
- cd "${_pkgname}"
- patch -p2 -i "${srcdir}/fix-vertical-alignment.patch"
}
build () {
@@ -42,6 +39,3 @@ package() {
cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install
}
-
-md5sums=('99514bf6d1a5ca8660dd0210ee58af28'
- 'f007c9814a88ca1ff8f017245b8ae7b6')
diff --git a/fix-vertical-alignment.patch b/fix-vertical-alignment.patch
deleted file mode 100644
index 136087c2bfe5..000000000000
--- a/fix-vertical-alignment.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/sources/awesome-widget/package/contents/ui/main.qml b/sources/awesome-widget/package/contents/ui/main.qml
-index 79c6ddf..0e20bc9 100644
---- a/sources/awesome-widget/package/contents/ui/main.qml
-+++ b/sources/awesome-widget/package/contents/ui/main.qml
-@@ -84,7 +84,7 @@ Item {
- // ui
- Text {
- id: text
-- anchors.fill: Plasmoid.Layout
-+ anchors.fill: parent
- renderType: Text.NativeRendering
- textFormat: Text.RichText
- wrapMode: plasmoid.configuration.wrapText ? Text.WordWrap : Text.NoWrap
-diff --git a/sources/desktop-panel/package/contents/ui/main.qml b/sources/desktop-panel/package/contents/ui/main.qml
-index 5a1e9b6..20f8732 100644
---- a/sources/desktop-panel/package/contents/ui/main.qml
-+++ b/sources/desktop-panel/package/contents/ui/main.qml
-@@ -57,7 +57,7 @@ Item {
-
- // ui
- GridLayout {
-- anchors.fill: Plasmoid.Layout
-+ anchors.fill: parent
- columns: plasmoid.configuration.verticalLayout ? 1 : dpAdds.numberOfDesktops()
- rows: plasmoid.configuration.verticalLayout ? dpAdds.numberOfDesktops() : 1
-