summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2022-10-30 17:28:52 +0100
committerMartino Pilia2022-10-30 17:28:52 +0100
commit8f303367a3b855fab4bfe0ecdcb104ca9c40d648 (patch)
treec610fb8660017ac094be709ac0f876f13547b32c
parent9ce6d1cf72eb28231e39dc285c34cb4309a36608 (diff)
downloadaur-plasma5-applets-ambientnoise.tar.gz
Add kdelibs4support to makedepends
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f07d3d51381..50940e6bd1f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = plasma5-applets-ambientnoise
pkgdesc = Plasmoid for ambient noise reproduction
pkgver = 0.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/m-pilia/plasma-applet-ambientnoise
arch = any
license = GPL
makedepends = extra-cmake-modules
makedepends = git
+ makedepends = kdelibs4support
depends = plasma-workspace
optdepends = anoise-media: noise files and icons
optdepends = anoise-community-extension1: noise files and icons
@@ -18,4 +19,3 @@ pkgbase = plasma5-applets-ambientnoise
sha256sums = d0936c0273b2877545edecb06316eed99ae4225b0bf1a889262e42ac5abaa314
pkgname = plasma5-applets-ambientnoise
-
diff --git a/PKGBUILD b/PKGBUILD
index a16acc909464..77dc8db1d40f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_upstream_name=plasma-applet-ambientnoise
pkgname=plasma5-applets-ambientnoise
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Plasmoid for ambient noise reproduction"
arch=('any')
url="https://github.com/m-pilia/plasma-applet-ambientnoise"
@@ -14,8 +14,11 @@ optdepends=('anoise-media: noise files and icons'
'anoise-community-extension3: noise files and icons'
'anoise-community-extension4: noise files and icons'
'anoise-community-extension5: noise files and icons')
-makedepends=('extra-cmake-modules'
- 'git')
+makedepends=(
+ 'extra-cmake-modules'
+ 'git'
+ 'kdelibs4support'
+)
source=("https://github.com/m-pilia/${_upstream_name}/archive/${pkgver}.tar.gz")
sha256sums=('d0936c0273b2877545edecb06316eed99ae4225b0bf1a889262e42ac5abaa314')
@@ -24,7 +27,7 @@ prepare() {
mkdir "${_build_dir}" || :
cd "${_build_dir}"
- cmake .. -DCMAKE_INSTALL_PREFIX="`kf5-config --prefix`" \
+ cmake .. -DCMAKE_INSTALL_PREFIX="$(kf5-config --prefix)" \
-DCMAKE_BUILD_TYPE=Release
}