summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2019-03-02 21:01:30 +0100
committerMartino Pilia2019-03-02 21:01:30 +0100
commit9ce6d1cf72eb28231e39dc285c34cb4309a36608 (patch)
tree046fb6a977cdf2d4dfadb188e8844b0f6b790038
parente772e54de7429160ed3ae60614357b96e5297f55 (diff)
downloadaur-9ce6d1cf72eb28231e39dc285c34cb4309a36608.tar.gz
Version 0.5.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82e98854ee10..6f07d3d51381 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = plasma5-applets-ambientnoise
pkgdesc = Plasmoid for ambient noise reproduction
- pkgver = 0.4.0
- pkgrel = 2
+ pkgver = 0.5.0
+ pkgrel = 1
url = https://github.com/m-pilia/plasma-applet-ambientnoise
arch = any
license = GPL
@@ -14,8 +14,8 @@ pkgbase = plasma5-applets-ambientnoise
optdepends = anoise-community-extension3: noise files and icons
optdepends = anoise-community-extension4: noise files and icons
optdepends = anoise-community-extension5: noise files and icons
- source = https://github.com/m-pilia/plasma-applet-ambientnoise/archive/0.4.0.tar.gz
- sha512sums = bc3de029fda7344bcfdd3e5d28b38d7f61a4c896905f9514303759203586d9020c72128a6b16a39078af017d6b3cd416b310bf43529a9bb3db7d1d0d08f74a98
+ source = https://github.com/m-pilia/plasma-applet-ambientnoise/archive/0.5.0.tar.gz
+ sha256sums = d0936c0273b2877545edecb06316eed99ae4225b0bf1a889262e42ac5abaa314
pkgname = plasma5-applets-ambientnoise
diff --git a/PKGBUILD b/PKGBUILD
index d80029d326f3..a16acc909464 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Package maintainer: Martino Pilia <martino.pilia@gmail.com>
_upstream_name=plasma-applet-ambientnoise
pkgname=plasma5-applets-ambientnoise
-pkgver=0.4.0
-pkgrel=2
+pkgver=0.5.0
+pkgrel=1
pkgdesc="Plasmoid for ambient noise reproduction"
arch=('any')
url="https://github.com/m-pilia/plasma-applet-ambientnoise"
@@ -16,22 +16,25 @@ optdepends=('anoise-media: noise files and icons'
'anoise-community-extension5: noise files and icons')
makedepends=('extra-cmake-modules'
'git')
-source=(https://github.com/m-pilia/${_upstream_name}/archive/${pkgver}.tar.gz)
-sha512sums=('bc3de029fda7344bcfdd3e5d28b38d7f61a4c896905f9514303759203586d9020c72128a6b16a39078af017d6b3cd416b310bf43529a9bb3db7d1d0d08f74a98')
+source=("https://github.com/m-pilia/${_upstream_name}/archive/${pkgver}.tar.gz")
+sha256sums=('d0936c0273b2877545edecb06316eed99ae4225b0bf1a889262e42ac5abaa314')
prepare() {
- mkdir -p build
+ export _build_dir="${srcdir}/${_upstream_name}-${pkgver}"/build
+
+ mkdir "${_build_dir}" || :
+ cd "${_build_dir}"
+ cmake .. -DCMAKE_INSTALL_PREFIX="`kf5-config --prefix`" \
+ -DCMAKE_BUILD_TYPE=Release
}
build() {
- cd build
- cmake ../${_upstream_name}-${pkgver} -DCMAKE_INSTALL_PREFIX="`kf5-config --prefix`" \
- -DCMAKE_BUILD_TYPE=Release
+ cd "${_build_dir}"
make
}
package() {
- cd build
+ cd "${_build_dir}"
make install DESTDIR="${pkgdir}"
- rm -f "$pkgdir/usr/share/icons/breeze/icon-theme.cache" || :
+ rm -rf "${pkgdir}"/usr/share/icons/*/icon-theme.cache
}