summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-02-04 11:08:25 +0100
committerMartino Pilia2018-02-04 11:08:25 +0100
commite797e0115a26e0a2ca5961ff12498a8d392ac660 (patch)
tree88a5ffd199340c8f52cc56f9ce891f6742a14a5b
parent2ca27ac288a2e9a849b668ceb6b9a2b71d0ad260 (diff)
downloadaur-e797e0115a26e0a2ca5961ff12498a8d392ac660.tar.gz
release 0.4.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8867a187ff6c..4f213cfb74ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = plasma5-applets-ambientnoise
pkgdesc = Plasmoid for ambient noise reproduction
- pkgver = 0.3.1
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/m-pilia/plasma-applet-ambientnoise
arch = any
@@ -12,8 +12,8 @@ pkgbase = plasma5-applets-ambientnoise
optdepends = anoise-community-extension1: noise files and icons
optdepends = anoise-community-extension2: noise files and icons
optdepends = anoise-community-extension3: noise files and icons
- source = https://github.com/m-pilia/plasma-applet-ambientnoise/archive/0.3.1.tar.gz
- sha512sums = b345d2f67150dacbd3b88b8519941da61dc38d112969258d6278d6652fd9b84bd43be87f413f2efae5907ec4a68a02d2dfaefccffece5ca674deec7ec3b27245
+ source = https://github.com/m-pilia/plasma-applet-ambientnoise/archive/0.4.0.tar.gz
+ sha512sums = bc3de029fda7344bcfdd3e5d28b38d7f61a4c896905f9514303759203586d9020c72128a6b16a39078af017d6b3cd416b310bf43529a9bb3db7d1d0d08f74a98
pkgname = plasma5-applets-ambientnoise
diff --git a/PKGBUILD b/PKGBUILD
index b67848cdf8e4..564602aeb574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Package maintainer: Martino Pilia <martino.pilia@gmail.com>
_upstream_name=plasma-applet-ambientnoise
pkgname=plasma5-applets-ambientnoise
-pkgver=0.3.1
+pkgver=0.4.0
pkgrel=1
pkgdesc="Plasmoid for ambient noise reproduction"
arch=('any')
@@ -15,7 +15,7 @@ optdepends=('anoise-media: noise files and icons'
makedepends=('extra-cmake-modules'
'git')
source=(https://github.com/m-pilia/${_upstream_name}/archive/${pkgver}.tar.gz)
-sha512sums=('b345d2f67150dacbd3b88b8519941da61dc38d112969258d6278d6652fd9b84bd43be87f413f2efae5907ec4a68a02d2dfaefccffece5ca674deec7ec3b27245')
+sha512sums=('bc3de029fda7344bcfdd3e5d28b38d7f61a4c896905f9514303759203586d9020c72128a6b16a39078af017d6b3cd416b310bf43529a9bb3db7d1d0d08f74a98')
prepare() {
mkdir -p build
@@ -23,13 +23,13 @@ prepare() {
build() {
cd build
- cmake ../${_upstream_name}-${pkgver} -DCMAKE_INSTALL_PREFIX="${pkgdir}`kf5-config --prefix`" \
+ cmake ../${_upstream_name}-${pkgver} -DCMAKE_INSTALL_PREFIX="`kf5-config --prefix`" \
-DCMAKE_BUILD_TYPE=Release
make
}
package() {
cd build
- make install
- rm -f "$pkgdir/usr/share/icons/breeze/icon-theme.cache" || echo
+ make install DESTDIR="${pkgdir}"
+ rm -f "$pkgdir/usr/share/icons/breeze/icon-theme.cache" || :
}