summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Harris2018-03-04 11:47:40 -0800
committerMike Harris2018-03-04 11:47:40 -0800
commit78f44f69c32d963dff86b15599c6d18f5df0bf66 (patch)
tree578a44421c0e1fac1ecb7fba150c84d03f395358
parent8ffb64e034df8b36204e5cc748aeea393c11e7a4 (diff)
downloadaur-78f44f69c32d963dff86b15599c6d18f5df0bf66.tar.gz
move pkgvr() above build
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5cb775654852..e10553474b95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,12 @@ backup=()
install=
source=("git+https://github.com/I-Dream-in-Code/kde-arch-update-plasmoid.git")
md5sums=("SKIP")
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ # cutting off 'foo-' prefix that presents in the git tag
+ printf "%s" "$(git describe --long | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+}
+
build() {
cd kde-arch-update-plasmoid
mkdir build
@@ -26,8 +32,3 @@ package(){
make DESTDIR="$pkgdir" install
}
-pkgver() {
- cd "$srcdir/${pkgname}"
- # cutting off 'foo-' prefix that presents in the git tag
- printf "%s" "$(git describe --long | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g')"
-}