summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcus Behrendt2017-03-02 18:39:36 +0100
committerMarcus Behrendt2017-03-02 18:39:36 +0100
commit04c086e6f48aee807406def9ec18ddb052c27e53 (patch)
tree0b4a081ce4b724b051d566c2dda5afba40d9e1bb
downloadaur-04c086e6f48aee807406def9ec18ddb052c27e53.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e44eaa89857a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Mar 2 17:39:12 UTC 2017
+pkgbase = plasma5-applets-keystate
+ pkgdesc = An accessibility Plasmoid that shows the status of various key on your keyboard (for example if Caps Lock is enabled or Meta is pressed).
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://store.kde.org/p/998903
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = plasma-workspace
+ provides = plasma5-applets-keystate
+ noextract = eu.blumenstingl.martin.keystateplasmoid.plasmoid
+ source = https://dl.opendesktop.org/api/files/download/id/1473016000/eu.blumenstingl.martin.keystateplasmoid.plasmoid
+ md5sums = 11a51e6528c5cdb3453c9a3395a4ba82
+
+pkgname = plasma5-applets-keystate
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..306788ebaf20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Marcus Behrendt <marcus (dot) behrendt (dot) eightysix (in digits) (at) bigbrothergoogle (dot) com
+
+pkgname=plasma5-applets-keystate
+pkgver=0.5
+pkgrel=1
+pkgdesc="An accessibility Plasmoid that shows the status of various key on your keyboard (for example if Caps Lock is enabled or Meta is pressed). "
+arch=('i686' 'x86_64')
+url="https://store.kde.org/p/998903"
+license=('GPL')
+depends=('plasma-workspace')
+makedepends=('unzip')
+provides=("${pkgname-*}")
+source=("https://dl.opendesktop.org/api/files/download/id/1473016000/eu.blumenstingl.martin.keystateplasmoid.plasmoid")
+md5sums=('11a51e6528c5cdb3453c9a3395a4ba82')
+
+_applet_name="eu.blumenstingl.martin.keystateplasmoid.plasmoid"
+
+noextract=("${_applet_name}")
+
+package() {
+ cd "${gitpkgname}"
+
+ _install_dir="${pkgdir}/usr/share/plasma/plasmoids/${_applet_name}"
+
+ mkdir -p "${_install_dir}"
+ unzip "${_applet_name}" -d "${_install_dir}"
+}
+