summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam Gathoye2017-09-01 20:02:49 +0200
committerWilliam Gathoye2017-09-01 20:02:49 +0200
commit9e8ba49752a480fa08a615a48cf6064a892b726f (patch)
tree3c333347ef5dc91a5600f066051d4682d1b75268
downloadaur-9e8ba49752a480fa08a615a48cf6064a892b726f.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b5ddcbebe1d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = plasma5-applets-netspeed
+ pkgdesc = Plasma 5 widget that displays the currently used network bandwidth
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/dfaust/plasma-applet-netspeed-widget
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ makedepends = extra-cmake-modules
+ source = https://github.com/dfaust/plasma-applet-netspeed-widget/archive/v1.4.tar.gz
+ sha512sums = 09d1ef424aa2a6675d56b7e92658546abab9cfcf24d48977efab681e2caa8ce840ad684f505ed04039e3137dff3f8b2bb1d31d2a95a43c8e2462742e79a96c0e
+
+pkgname = plasma5-applets-netspeed
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5804da5a0c61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: William Gathoye <william + aur at gathoye dot be>
+
+pkgname=plasma5-applets-netspeed
+pkgver=1.4
+pkgrel=1
+pkgdesc='Plasma 5 widget that displays the currently used network bandwidth'
+arch=('i686' 'x86_64')
+
+url='https://github.com/dfaust/plasma-applet-netspeed-widget'
+license=('GPL2')
+
+makedepends=('git' 'cmake' 'extra-cmake-modules')
+
+source=(
+ "https://github.com/dfaust/plasma-applet-netspeed-widget/archive/v${pkgver}.tar.gz"
+)
+sha512sums=(
+ '09d1ef424aa2a6675d56b7e92658546abab9cfcf24d48977efab681e2caa8ce840ad684f505ed04039e3137dff3f8b2bb1d31d2a95a43c8e2462742e79a96c0e'
+)
+
+build() {
+ cd "plasma-applet-netspeed-widget-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "plasma-applet-netspeed-widget-${pkgver}"
+ make DESTDIR="$pkgdir/" install
+}
+