summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKotelnik2015-06-16 20:52:32 +0200
committerKotelnik2015-06-16 20:52:32 +0200
commite1be18a34f3be1c7fa4a4fe81793eb3d6ae61fc3 (patch)
tree765e387f15477347eaab88eac9b6448c671bf340
parent95ebf1ba97f9a69ebfd699bb3cecf89c73a35171 (diff)
downloadaur-e1be18a34f3be1c7fa4a4fe81793eb3d6ae61fc3.tar.gz
PKGBUILD fix
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 59a250002fa2..85432545168c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Martin Kostolný <clearmartin at zoho dot com>
pkgname=plasma5-applets-network-monitor-git
-_pkgname=plasma-applet-network-monitor
+_pkgname=plasma5-applets-network-monitor
+_gitpkgname=plasma-applet-network-monitor
pkgver=r15.e1ac837
pkgrel=1
pkgdesc="Plasmoid for Plasma 5. Shows network speed of currently active connections."
arch=('any')
-url="https://github.com/kotelnik/plasma-applet-network-monitor"
+url="https://github.com/kotelnik/$_gitpkgname"
license=('GPL')
depends=('plasma-workspace' 'qt5-graphicaleffects')
makedepends=('git' 'extra-cmake-modules')
-conflicts=("${pkgname%-*}")
-provides=("${pkgname%-*}")
-source=('git://github.com/kotelnik/plasma-applet-network-monitor.git')
+conflicts=("${_pkgname-*}")
+provides=("${_pkgname-*}")
+source=("git://github.com/kotelnik/$_gitpkgname.git")
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd "${_gitpkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "${_pkgname}"
+ cd "${_gitpkgname}"
mkdir -p build
cd build
@@ -35,7 +36,7 @@ build() {
}
package() {
- cd "${_pkgname}"/build
+ cd "${_gitpkgname}"/build
make install DESTDIR="${pkgdir}"
}