summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrbn422019-11-27 13:06:25 +0800
committerrbn422019-11-27 13:06:25 +0800
commitd429d7dd2708321b19a4e699d92b55fd3f24c7e0 (patch)
tree4bd8491fc227f12926e626331d1828be22af403f
parent2c8f9d67f09264ac31415e6386e3ec6ba7a23dd7 (diff)
downloadaur-d429d7dd2708321b19a4e699d92b55fd3f24c7e0.tar.gz
Remove qt3d dependency
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eec26d4ae7e8..bda0789731d8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = plasma5-applets-panon-git
pkgdesc = A Different Audio Spectrum Analyzer for KDE Plasma
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://github.com/rbn42/panon
arch = any
license = GPL3
@@ -14,7 +14,6 @@ pkgbase = plasma5-applets-panon-git
depends = python-cffi
depends = python-websockets
depends = qt5-websockets
- depends = qt5-3d
provides = plasma5-applets-panon-git
conflicts = plasma5-applets-panon-git
conflicts = plasma5-applets-panon
diff --git a/PKGBUILD b/PKGBUILD
index 3bc8751b57c1..19b148f32edb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# based on https://github.com/rbn42/panon/blob/master/PKGBUILD
# Maintainer: Robin <rbn dot 86 et bigbrothergoogle>
# Contributor: Marcus Behrendt <marcus dot behrendt dot 86 et bigbrothergoogle>
# Contributor: Philipp A. <flying-sheep@github.com>
@@ -11,7 +10,7 @@ pkgdesc="A Different Audio Spectrum Analyzer for KDE Plasma"
arch=('any')
url="http://github.com/rbn42/panon"
license=('GPL3')
-depends=('plasma-workspace' 'python-docopt' 'python-numpy' 'python-pillow' 'python-pyaudio' 'python-cffi' 'python-websockets' 'qt5-websockets' 'qt5-3d')
+depends=('plasma-workspace' 'python-docopt' 'python-numpy' 'python-pillow' 'python-pyaudio' 'python-cffi' 'python-websockets' 'qt5-websockets')
makedepends=('git')
provides=('plasma5-applets-panon-git')
conflicts=('plasma5-applets-panon-git' 'plasma5-applets-panon')
@@ -20,10 +19,23 @@ md5sums=('SKIP')
package() {
cd "${srcdir}/${_basename}"
+
+ # Download SoundCard and hsluv-glsl
+ git submodule update --init
+
+ # Remove shader examples
rm ./kde/plasmoid/contents/shaders/example-*
+
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${_basename%-*}/LICENSE"
+ install -Dm644 third_party/hsluv-glsl/LICENCE.md "$pkgdir/usr/share/licenses/${_basename%-*}/hsluv-glsl/LICENCE.md"
+ install -Dm644 third_party/SoundCard/LICENSE "$pkgdir/usr/share/licenses/${_basename%-*}/SoundCard/LICENSE"
cd kde
kpackagetool5 -p "$pkgdir/usr/share/plasma/plasmoids/" -t Plasma/Applet -i plasmoid
- rm "$pkgdir/usr/share/plasma/plasmoids/kpluginindex.json"
+
+ # If an index is generated, remove it.
+ path_index="$pkgdir/usr/share/plasma/plasmoids/kpluginindex.json"
+ if [ -e "$path_index" ];then
+ rm "$path_index"
+ fi
}