summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2018-05-01 22:24:09 -0600
committerAinola2018-05-01 22:24:09 -0600
commit05f47baa35783269812df56cbd083f9447623097 (patch)
tree1e2d6df8fe50c58a7580340b2c400ea50d523bd1
downloadaur-05f47baa35783269812df56cbd083f9447623097.tar.gz
initial
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bd835d8eb56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed May 2 04:23:57 UTC 2018
+pkgbase = plasma5-applets-plasma-pass-git
+ pkgdesc = Plasma applet for pass.
+ pkgver = r16.d067ec5
+ pkgrel = 1
+ url = https://cgit.kde.org/scratch/dvratil/plasma-pass.git
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = cmake
+ makedepends = git
+ depends = pass
+ depends = plasma-framework
+ conflicts = renameutils
+ conflicts = imv
+ source = git+https://anongit.kde.org/scratch/dvratil/plasma-pass.git
+ md5sums = SKIP
+ sha256sums = SKIP
+
+pkgname = plasma5-applets-plasma-pass-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af2899cf1505
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Ainola
+pkgname=plasma5-applets-plasma-pass-git
+pkgver=r16.d067ec5
+pkgrel=1
+pkgdesc='Plasma applet for pass.'
+url="https://cgit.kde.org/scratch/dvratil/plasma-pass.git"
+arch=('x86_64' 'i686')
+license=('custom') # No license in the repo yet as of writing.
+depends=('pass' 'plasma-framework')
+makedepends=('cmake' 'git')
+conflicts=('renameutils' 'imv')
+source=("git+https://anongit.kde.org/scratch/dvratil/plasma-pass.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/plasma-pass"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/plasma-pass"
+ [ -d build ] && rm -Rf build
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+}
+package(){
+ cd "${srcdir}/plasma-pass/build"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums=('SKIP')