summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Kudelin2020-11-18 22:42:59 +0300
committerAnton Kudelin2020-11-18 22:42:59 +0300
commit6df528722f107b64f1a11dbc2e5fbc45075cff56 (patch)
tree965c57db5ac58595dd13f4d7d838b725875414ba
parentf2f694fd0bfa0192fb07d6d78d5d30ac0f672c38 (diff)
downloadaur-6df528722f107b64f1a11dbc2e5fbc45075cff56.tar.gz
Applied a fix from PR #64
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD37
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80c8e6f43033..9813b9235279 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = plasma5-applets-plasma-pstate
pkgdesc = Intel P-state and CPUFreq Manager Widget
pkgver = 1.0.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jsalatas/plasma-pstate
arch = any
license = GPL2
- makedepends = sed
depends = plasma-workspace
optdepends = libsmbios: Dell's Thermal Management Feature
- optdepends = x86_energy_perf_policy: If your processor doesn't support EPP i.e. older generations without HWP
- source = https://github.com/jsalatas/plasma-pstate/archive/1.0.6.tar.gz
+ optdepends = x86_energy_perf_policy: For processors without the EPP support EPP i.e. older generations without HWP
+ source = plasma5-applets-plasma-pstate-1.0.6.tar.gz::https://github.com/jsalatas/plasma-pstate/archive/1.0.6.tar.gz
sha256sums = b2abb03e9fe939fd6f516b8e65ef0badad2558c0b55687dd044756523e3900dc
pkgname = plasma5-applets-plasma-pstate
diff --git a/PKGBUILD b/PKGBUILD
index 3bfa2d71ed9e..5efdd7fceaa5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,35 @@
# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
-# Contributor: Marcus Behrendt <marcus dot behrendt dot eightysix(in numbers) at bigbrothergoogle dot com
+# Contributor: Marcus Behrendt <marcus dot behrendt dot 86 at bigbrothergoogle dot com>
_applet_name=plasma-pstate
pkgname=plasma5-applets-${_applet_name}
pkgver=1.0.6
-pkgrel=2
+pkgrel=3
pkgdesc="Intel P-state and CPUFreq Manager Widget"
-url="https://github.com/jsalatas/${_applet_name}"
+url="https://github.com/jsalatas/$_applet_name"
arch=('any')
license=('GPL2')
depends=('plasma-workspace')
-makedepends=('sed')
optdepends=("libsmbios: Dell's Thermal Management Feature"
- "x86_energy_perf_policy: If your processor doesn't support EPP i.e. older generations without HWP")
-source=("https://github.com/jsalatas/${_applet_name}/archive/${pkgver}.tar.gz")
+ "x86_energy_perf_policy: For processors without the EPP support EPP i.e. older generations without HWP")
+source=($pkgname-$pkgver.tar.gz::"$url/archive/$pkgver.tar.gz")
sha256sums=('b2abb03e9fe939fd6f516b8e65ef0badad2558c0b55687dd044756523e3900dc')
-package() {
- cd $srcdir/$_applet_name-$pkgver
+prepare() {
+ cd "$srcdir/$_applet_name-$pkgver/gr.ictpro.jsalatas.plasma.pstate/contents/ui"
+ sed -i "s/parent.width/units.gridUnit * 4/" ComboBox.qml
+}
- _plasmoid_dir=$pkgdir/usr/share/plasma/plasmoids
- mkdir -p $_plasmoid_dir
- cp -r "gr.ictpro.jsalatas.plasma.pstate" $_plasmoid_dir
+package() {
+ _plasmoid_dir="$pkgdir/usr/share/plasma/plasmoids"
+ _sudoers_dir="$pkgdir/etc/sudoers.d"
- _sudoers_dir=$pkgdir/etc/sudoers.d
- mkdir -p $_sudoers_dir
- chmod 750 $_sudoers_dir
- install 99-plasma-pstate $_sudoers_dir
- sed -i 's/sudo/wheel/' $_sudoers_dir/99-plasma-pstate
- chmod 400 $_sudoers_dir/99-plasma-pstate
+ cd "$srcdir/$_applet_name-$pkgver"
+ mkdir -p "$_plasmoid_dir"
+ cp -r "gr.ictpro.jsalatas.plasma.pstate" "$_plasmoid_dir"
+ mkdir -p "$_sudoers_dir"
+ chmod 750 "$_sudoers_dir"
+ install 99-plasma-pstate "$_sudoers_dir"
+ sed -i 's/sudo/wheel/' "$_sudoers_dir/99-plasma-pstate"
+ chmod 400 "$_sudoers_dir/99-plasma-pstate"
}